summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-19 11:32:31 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-19 11:33:09 +1300
commit0f9fdd50a62eb48ccfb8658113ebd91147c1a7b7 (patch)
tree21aaacad7ddb23fd20ea06b284c30c8be946ba79 /dev-perl/ConfigReader/files
parentapp-admin/logstash-bin: drop old. (diff)
downloadgentoo-0f9fdd50a62eb48ccfb8658113ebd91147c1a7b7.tar.gz
gentoo-0f9fdd50a62eb48ccfb8658113ebd91147c1a7b7.tar.bz2
gentoo-0f9fdd50a62eb48ccfb8658113ebd91147c1a7b7.zip
dev-perl/ConfigReader: EAPI6 + Toolchain Love
- EAPI6 - Add a working Makefile.PL - Add basic tests - Tests enabled - Now works like every other perl module. Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/ConfigReader/files')
-rw-r--r--dev-perl/ConfigReader/files/ConfigReader-0.500.0-makefile-tests.patch58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-perl/ConfigReader/files/ConfigReader-0.500.0-makefile-tests.patch b/dev-perl/ConfigReader/files/ConfigReader-0.500.0-makefile-tests.patch
new file mode 100644
index 000000000000..d074351cab53
--- /dev/null
+++ b/dev-perl/ConfigReader/files/ConfigReader-0.500.0-makefile-tests.patch
@@ -0,0 +1,58 @@
+From ba8219e0ca0bde2a3635a589659d8840961dba7b Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Thu, 19 Oct 2017 11:10:23 +1300
+Subject: Add basic Makefile.PL and Tests
+
+This distribution is so old, it could possibly have been authored
+before EUMM and friends were common practice.
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=13921
+---
+ Makefile.PL | 15 +++++++++++++++
+ t/compile.t | 12 ++++++++++++
+ 2 files changed, 27 insertions(+)
+ create mode 100644 Makefile.PL
+ create mode 100644 t/compile.t
+
+diff --git a/Makefile.PL b/Makefile.PL
+new file mode 100644
+index 0000000..f272d63
+--- /dev/null
++++ b/Makefile.PL
+@@ -0,0 +1,15 @@
++use ExtUtils::MakeMaker;
++
++WriteMakefile(
++ NAME => 'ConfigReader',
++ VERSION_FROM => "DirectiveStyle.pm",
++ ABSTRACT_FROM => "ConfigReader.pod",
++ LICENSE => "gpl",
++ PREREQ_PM => {},
++ PM => {
++ 'ConfigReader.pod' => '$(INST_LIB)/ConfigReader.pod',
++ 'DirectiveStyle.pm' => '$(INST_LIB)/ConfigReader/DirectiveStyle.pm',
++ 'Spec.pm' => '$(INST_LIB)/ConfigReader/Spec.pm',
++ 'Values.pm' => '$(INST_LIB)/ConfigReader/Values.pm',
++ },
++);
+diff --git a/t/compile.t b/t/compile.t
+new file mode 100644
+index 0000000..46c1f1d
+--- /dev/null
++++ b/t/compile.t
+@@ -0,0 +1,12 @@
++use strict;
++use warnings;
++
++use Test::More;
++
++require_ok("ConfigReader::DirectiveStyle");
++require_ok("ConfigReader::Spec");
++require_ok("ConfigReader::Values");
++
++done_testing;
++
++
+--
+2.14.2
+