summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-06-29 20:47:40 +1200
committerKent Fredric <kentnl@gentoo.org>2020-06-29 20:48:17 +1200
commitcea8a1fea4c3d2e5e64652f143c63ea0b761b01a (patch)
tree55df6fceb14bb1d2fbb1bafe5132df52c6ce9cde /dev-perl/Convert-PEM
parentx11-drivers/nvidia-drivers: Update CONFIG_CHECK (diff)
downloadgentoo-cea8a1fea4c3d2e5e64652f143c63ea0b761b01a.tar.gz
gentoo-cea8a1fea4c3d2e5e64652f143c63ea0b761b01a.tar.bz2
gentoo-cea8a1fea4c3d2e5e64652f143c63ea0b761b01a.zip
dev-perl/Convert-PEM: -r bump for EAPI7
- EAPI7 - Parallel tests - Clarify dependencies - Remove unused/empty variable assignments Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Convert-PEM')
-rw-r--r--dev-perl/Convert-PEM/Convert-PEM-0.80.0-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Convert-PEM/Convert-PEM-0.80.0-r2.ebuild b/dev-perl/Convert-PEM/Convert-PEM-0.80.0-r2.ebuild
new file mode 100644
index 000000000000..f659a54cd1e5
--- /dev/null
+++ b/dev-perl/Convert-PEM/Convert-PEM-0.80.0-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=BTROTT
+DIST_VERSION=0.08
+inherit perl-module
+
+DESCRIPTION="Read/write encrypted ASN.1 PEM files"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+
+RDEPEND="
+ dev-perl/Class-ErrorHandler
+ >=dev-perl/Convert-ASN1-0.100.0
+ dev-perl/Crypt-DES_EDE3
+ virtual/perl-Digest-MD5
+ virtual/perl-MIME-Base64
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+"
+PATCHES=(
+ "${FILESDIR}/${P}-526.patch"
+ "${FILESDIR}/${P}-decryptiontest.patch"
+ "${FILESDIR}/${P}-testbuilder.patch"
+)