summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-04-12 19:49:44 +1200
committerKent Fredric <kentnl@gentoo.org>2018-04-15 20:35:55 +1200
commit086c72f0ff169a77ce73791b2397f38dd5c49066 (patch)
tree824a38118667f06baa8ac80105068d498f76cf4b /dev-perl/Coro
parentdev-perl/Cookie-Baker-XS: Cleanup old (diff)
downloadgentoo-086c72f0ff169a77ce73791b2397f38dd5c49066.tar.gz
gentoo-086c72f0ff169a77ce73791b2397f38dd5c49066.tar.bz2
gentoo-086c72f0ff169a77ce73791b2397f38dd5c49066.zip
dev-perl/Coro: Cleanup old
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Coro')
-rw-r--r--dev-perl/Coro/Coro-6.511.0.ebuild36
-rw-r--r--dev-perl/Coro/Manifest1
-rw-r--r--dev-perl/Coro/files/6.511.0-argarray.patch42
-rw-r--r--dev-perl/Coro/files/6.511.0-padoffset.patch60
4 files changed, 0 insertions, 139 deletions
diff --git a/dev-perl/Coro/Coro-6.511.0.ebuild b/dev-perl/Coro/Coro-6.511.0.ebuild
deleted file mode 100644
index 1be8e564e4bc..000000000000
--- a/dev-perl/Coro/Coro-6.511.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DIST_AUTHOR=MLEHMANN
-DIST_VERSION=6.511
-inherit perl-module
-
-DESCRIPTION="The only real threads in perl"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="vanilla"
-
-RDEPEND="
- >=dev-perl/AnyEvent-5
- >=dev-perl/Guard-0.500.0
- virtual/perl-Scalar-List-Utils
- >=virtual/perl-Storable-2.150.0
- dev-perl/common-sense
-"
-DEPEND="${RDEPEND}
- dev-perl/Canary-Stability
- >=virtual/perl-ExtUtils-MakeMaker-6.520.0
-"
-
-src_prepare() {
- if ! use vanilla; then
- elog "This release includes 3rd party patches for Perl 5.24 and 5.26 compatibility."
- elog "Please do not contact upstream directly regarding problems arising from this."
- eapply "${FILESDIR}/${PV}-argarray.patch"
- eapply "${FILESDIR}/${PV}-padoffset.patch"
- fi
- perl-module_src_prepare
-}
diff --git a/dev-perl/Coro/Manifest b/dev-perl/Coro/Manifest
index 664766c1ddd9..fd2a02abdf9f 100644
--- a/dev-perl/Coro/Manifest
+++ b/dev-perl/Coro/Manifest
@@ -1,2 +1 @@
-DIST Coro-6.511.tar.gz 195173 BLAKE2B aa0c83c464853f9945692f41e6119dde241b098060dc1fe4c7a42e89e75a64a1353615b36f4dabd5499e701d4537cdc5a1ab16b6eb82cfaa80cea6a3fd32b6bb SHA512 c3e591539e3313403496d3396e68147942e45590732bbaed7b3020fdc79e1e726c3addc3fc5d5d3e173c2b3faff4de2a9d0bae19f91cdc684285c2751b809681
DIST Coro-6.514.tar.gz 195122 BLAKE2B d512a990f54e22af20ea91165817d00bab20dcbe0e9111988f704799556cf246f96a40a8b59b56977edefbabf8830453662001ceb35eb4d0f1761ce7c3da3fb7 SHA512 340eea9bc2a33c40813f4852d3a12ff947426fd329a4867a36262a9ece936c9e43d36ba5e4355d1f8f91cb40690de3bb1637ab0b0651518c22fb17a34ee90b37
diff --git a/dev-perl/Coro/files/6.511.0-argarray.patch b/dev-perl/Coro/files/6.511.0-argarray.patch
deleted file mode 100644
index 243494448adc..000000000000
--- a/dev-perl/Coro/files/6.511.0-argarray.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 38fe74765a4cbf1003cc2011559bf83b05b10e46 Mon Sep 17 00:00:00 2001
-From: David Mitchell <davem@iabyn.com>
-Date: Tue, 3 May 2016 22:25:48 +0100
-Subject: [PATCH 3/5] Coro: handle argarray removal in 5.23.8
-
----
- Coro/State.xs | 12 +++++++++++-
- 1 file changed, 11 insertions(+), 1 deletion(-)
-
-diff --git a/Coro/State.xs b/Coro/State.xs
-index 93c2c5b..28264c5 100644
---- a/Coro/State.xs
-+++ b/Coro/State.xs
-@@ -1415,6 +1415,7 @@ runops_trace (pTHX)
- if (CxTYPE (cx) == CXt_SUB && oldcxix < cxstack_ix)
- {
- dSP;
-+ AV *argarray;
- GV *gv = CvGV (cx->blk_sub.cv);
- SV *fullname = sv_2mortal (newSV (0));
-
-@@ -1428,7 +1429,16 @@ runops_trace (pTHX)
- PUSHMARK (SP);
- PUSHs (&PL_sv_yes);
- PUSHs (fullname);
-- PUSHs (CxHASARGS (cx) ? sv_2mortal (newRV_inc ((SV *)cx->blk_sub.argarray)) : &PL_sv_undef);
-+ argarray =
-+# if PERL_VERSION_ATLEAST(5,23,8)
-+ ((AV*)(AvARRAY(MUTABLE_AV(
-+ PadlistARRAY(CvPADLIST(cx->blk_sub.cv))[
-+ CvDEPTH(cx->blk_sub.cv)]))[0]));
-+#else
-+ cx->blk_sub.argarray;
-+#endif
-+
-+ PUSHs (CxHASARGS (cx) ? sv_2mortal (newRV_inc ((SV *)argarray)) : &PL_sv_undef);
- PUTBACK;
- cb = hv_fetch ((HV *)SvRV (coro_current), "_trace_sub_cb", sizeof ("_trace_sub_cb") - 1, 0);
- if (cb) call_sv (*cb, G_KEEPERR | G_EVAL | G_VOID | G_DISCARD);
---
-2.4.11
-
diff --git a/dev-perl/Coro/files/6.511.0-padoffset.patch b/dev-perl/Coro/files/6.511.0-padoffset.patch
deleted file mode 100644
index 2fb34c0791be..000000000000
--- a/dev-perl/Coro/files/6.511.0-padoffset.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-From b48bc3a8141e5f27ce48b6f3ebbe2ba6ee7bda94 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
-Date: Tue, 23 May 2017 15:12:06 +0200
-Subject: [PATCH] Adjust comppad_name_ variable sizes to Perl 5.26.0
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Perl 5.26.0 changed some variable types in this commit:
-
-commit d12be05dd0210a08e077f0cc9586a5a963122547
-Author: David Mitchell <davem@iabyn.com>
-Date: Mon Sep 26 15:56:08 2016 +0100
-
- make PL_ pad vars be of type PADOFFSET
-
- Now that that PADOFFSET is signed, make
-
- PL_comppad_name_fill
- PL_comppad_name_floor
- PL_padix
- PL_constpadix
- PL_padix_floor
- PL_min_intro_pending
- PL_max_intro_pending
-
- be of type PADOFFSET rather than I32, to match the rest of the pad
- interface.
-
- At the same time, change various I32 local vars in pad.c functions to be
- PADOFFSET.
-
-This patch adjusts Coro to the changes.
-
-Signed-off-by: Petr Písař <ppisar@redhat.com>
----
- Coro/state.h | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/Coro/state.h b/Coro/state.h
-index 9a3e84f..8d6d067 100644
---- a/Coro/state.h
-+++ b/Coro/state.h
-@@ -83,8 +83,13 @@ VAR(compcv, CV *) /* currently compiling subroutine */
-
- VAR(comppad, AV *) /* storage for lexically scoped temporaries */
- VAR(comppad_name, AV *) /* variable names for "my" variables */
-+#if PERL_VERSION_ATLEAST (5,25,6)
-+VAR(comppad_name_fill, PADOFFSET) /* last "introduced" variable offset */
-+VAR(comppad_name_floor, PADOFFSET) /* start of vars in innermost block */
-+#else
- VAR(comppad_name_fill, I32) /* last "introduced" variable offset */
- VAR(comppad_name_floor, I32) /* start of vars in innermost block */
-+#endif
-
- VAR(runops, runops_proc_t) /* for tracing support */
-
---
-2.9.4
-