summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-07-12 00:07:49 +1200
committerKent Fredric <kentnl@gentoo.org>2016-07-12 00:09:41 +1200
commitfedc5555ce3645f4501b0e76844c55e63a14d892 (patch)
treeb71c083aa5c0d6dbac480482ca5904b064ffc5ae /dev-perl/Coro
parentprofiles: p.mask net-dns/namecoin{d,-qt}, bug #585726 (diff)
downloadgentoo-fedc5555ce3645f4501b0e76844c55e63a14d892.tar.gz
gentoo-fedc5555ce3645f4501b0e76844c55e63a14d892.tar.bz2
gentoo-fedc5555ce3645f4501b0e76844c55e63a14d892.zip
dev-perl/Coro: Bump to version 6.511.0
- EAPI6 - Include P5P Patch for 5.24 compat with lots of warning bells. - USE="vanilla" to provide the upstream experience ( which is presently broken on 5.24 ) Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/Coro')
-rw-r--r--dev-perl/Coro/Coro-6.511.0.ebuild36
-rw-r--r--dev-perl/Coro/Manifest1
-rw-r--r--dev-perl/Coro/files/6.511.0-argarray.patch42
3 files changed, 79 insertions, 0 deletions
diff --git a/dev-perl/Coro/Coro-6.511.0.ebuild b/dev-perl/Coro/Coro-6.511.0.ebuild
new file mode 100644
index 000000000000..62ce061b944b
--- /dev/null
+++ b/dev-perl/Coro/Coro-6.511.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=MLEHMANN
+DIST_VERSION=6.511
+inherit perl-module
+
+DESCRIPTION="The only real threads in perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vanilla"
+
+RDEPEND="
+ >=dev-perl/AnyEvent-5
+ >=dev-perl/Guard-0.500.0
+ virtual/perl-Scalar-List-Utils
+ >=virtual/perl-Storable-2.150.0
+ dev-perl/common-sense
+"
+DEPEND="${RDEPEND}
+ dev-perl/Canary-Stability
+ >=virtual/perl-ExtUtils-MakeMaker-6.520.0
+"
+
+src_prepare() {
+ if ! use vanilla; then
+ ewarn "This release includes a 3rd party argarray patch for Perl 5.24 Compat."
+ ewarn "Please do not contact upstream directly regarding problems arising from this."
+ eapply "${FILESDIR}/${PV}-argarray.patch"
+ fi
+ perl-module_src_prepare
+}
diff --git a/dev-perl/Coro/Manifest b/dev-perl/Coro/Manifest
index 5f09f658aab8..6255c813cb87 100644
--- a/dev-perl/Coro/Manifest
+++ b/dev-perl/Coro/Manifest
@@ -1 +1,2 @@
DIST Coro-6.4801.tar.gz 190759 SHA256 e20d4987244ee982ffab00fc66f4897e6c9d4c8b7aa86889c19228006a60789c SHA512 2b53a4feb4d187d74d09c30c95765c2f8b416f95f7026f1d7e6fd37bc300f041fd8f72a44017036920c242d0ba7ab21bc32cf7183570fad9eeab706df60f7684 WHIRLPOOL be44764aa5a42c510721b7b7a6b17bd79acf1127667c8fd3eb8c0d92fc47e4c0110505b06425ee03ef56df5a9e8871c8f14abc9d29fa704e0628bd52521a1d78
+DIST Coro-6.511.tar.gz 195173 SHA256 7e3ed48cdb3f3742d94ae3ab3d088c3ab818c521f8681da6c5f656bd49ac53ea SHA512 c3e591539e3313403496d3396e68147942e45590732bbaed7b3020fdc79e1e726c3addc3fc5d5d3e173c2b3faff4de2a9d0bae19f91cdc684285c2751b809681 WHIRLPOOL 3a56fca3116d1b2b6cd727078ebed9811aa627756c08c439ee6bceabba75117c904b692bf147f251dcd978abcf63e0d0f24e9ef068adf1592c4ff9539ae64daf
diff --git a/dev-perl/Coro/files/6.511.0-argarray.patch b/dev-perl/Coro/files/6.511.0-argarray.patch
new file mode 100644
index 000000000000..243494448adc
--- /dev/null
+++ b/dev-perl/Coro/files/6.511.0-argarray.patch
@@ -0,0 +1,42 @@
+From 38fe74765a4cbf1003cc2011559bf83b05b10e46 Mon Sep 17 00:00:00 2001
+From: David Mitchell <davem@iabyn.com>
+Date: Tue, 3 May 2016 22:25:48 +0100
+Subject: [PATCH 3/5] Coro: handle argarray removal in 5.23.8
+
+---
+ Coro/State.xs | 12 +++++++++++-
+ 1 file changed, 11 insertions(+), 1 deletion(-)
+
+diff --git a/Coro/State.xs b/Coro/State.xs
+index 93c2c5b..28264c5 100644
+--- a/Coro/State.xs
++++ b/Coro/State.xs
+@@ -1415,6 +1415,7 @@ runops_trace (pTHX)
+ if (CxTYPE (cx) == CXt_SUB && oldcxix < cxstack_ix)
+ {
+ dSP;
++ AV *argarray;
+ GV *gv = CvGV (cx->blk_sub.cv);
+ SV *fullname = sv_2mortal (newSV (0));
+
+@@ -1428,7 +1429,16 @@ runops_trace (pTHX)
+ PUSHMARK (SP);
+ PUSHs (&PL_sv_yes);
+ PUSHs (fullname);
+- PUSHs (CxHASARGS (cx) ? sv_2mortal (newRV_inc ((SV *)cx->blk_sub.argarray)) : &PL_sv_undef);
++ argarray =
++# if PERL_VERSION_ATLEAST(5,23,8)
++ ((AV*)(AvARRAY(MUTABLE_AV(
++ PadlistARRAY(CvPADLIST(cx->blk_sub.cv))[
++ CvDEPTH(cx->blk_sub.cv)]))[0]));
++#else
++ cx->blk_sub.argarray;
++#endif
++
++ PUSHs (CxHASARGS (cx) ? sv_2mortal (newRV_inc ((SV *)argarray)) : &PL_sv_undef);
+ PUTBACK;
+ cb = hv_fetch ((HV *)SvRV (coro_current), "_trace_sub_cb", sizeof ("_trace_sub_cb") - 1, 0);
+ if (cb) call_sv (*cb, G_KEEPERR | G_EVAL | G_VOID | G_DISCARD);
+--
+2.4.11
+