summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-01 06:38:37 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-01 06:38:57 +1200
commit2fa6517a78db324a41b2ab9460afebd8bf6b862d (patch)
tree75bcec13c1d53c3817e61dc1b1619d4baf806594 /dev-perl/Crypt-DH-GMP
parentRevert "net-libs/libmicrohttpd: remove older versions" (diff)
downloadgentoo-2fa6517a78db324a41b2ab9460afebd8bf6b862d.tar.gz
gentoo-2fa6517a78db324a41b2ab9460afebd8bf6b862d.tar.bz2
gentoo-2fa6517a78db324a41b2ab9460afebd8bf6b862d.zip
dev-perl/Crypt-DH-GMP: -r bump for EAPI7 + fixes
- EAPI7 - Convert "sed" to "patch" - Ensure CFLAGS passed to make Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Crypt-DH-GMP')
-rw-r--r--dev-perl/Crypt-DH-GMP/Crypt-DH-GMP-0.0.120-r1.ebuild42
-rw-r--r--dev-perl/Crypt-DH-GMP/files/Crypt-DH-GMP-0.00012-no-dot-inc.patch21
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-perl/Crypt-DH-GMP/Crypt-DH-GMP-0.0.120-r1.ebuild b/dev-perl/Crypt-DH-GMP/Crypt-DH-GMP-0.0.120-r1.ebuild
new file mode 100644
index 000000000000..30f27ae19248
--- /dev/null
+++ b/dev-perl/Crypt-DH-GMP/Crypt-DH-GMP-0.0.120-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DMAKI
+DIST_VERSION=0.00012
+inherit perl-module
+
+DESCRIPTION="Crypt::DH Using GMP Directly"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=virtual/perl-XSLoader-0.20.0
+ >=dev-libs/gmp-4.0.0:0
+"
+DEPEND="
+ >=dev-libs/gmp-4.0.0:0
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Devel-CheckLib-0.400.0
+ >=virtual/perl-Devel-PPPort-3.190.0
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ >=virtual/perl-ExtUtils-ParseXS-3.180.0
+ test? (
+ dev-perl/Test-Requires
+ virtual/perl-Test-Simple
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.00012-no-dot-inc.patch"
+)
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
diff --git a/dev-perl/Crypt-DH-GMP/files/Crypt-DH-GMP-0.00012-no-dot-inc.patch b/dev-perl/Crypt-DH-GMP/files/Crypt-DH-GMP-0.00012-no-dot-inc.patch
new file mode 100644
index 000000000000..81df0b2dc5ba
--- /dev/null
+++ b/dev-perl/Crypt-DH-GMP/files/Crypt-DH-GMP-0.00012-no-dot-inc.patch
@@ -0,0 +1,21 @@
+From 015df91fa006921333c47088d293845f8b8c38f9 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Wed, 1 Jul 2020 06:31:46 +1200
+Subject: Include '.' in @INC on perl 5.26+
+
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 8c03b4a..72cc677 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,3 +1,4 @@
++use lib '.';
+ use inc::Module::Install;
+
+ my @DEFINES;
+--
+2.27.0
+