summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-02 20:24:39 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-02 20:28:24 +1200
commitd18e90bc6d14e3c68343471df7b90e28c4884b1a (patch)
tree0144af11382ff1944b7bb274b97f01bedf334889 /dev-perl/Crypt-RSA
parentgnome-extra/gnome-commander: Drop 1.10.2 (diff)
downloadgentoo-d18e90bc6d14e3c68343471df7b90e28c4884b1a.tar.gz
gentoo-d18e90bc6d14e3c68343471df7b90e28c4884b1a.tar.bz2
gentoo-d18e90bc6d14e3c68343471df7b90e28c4884b1a.zip
dev-perl/Crypt-RSA: -r bump for EAPI7 + fixes
- EAPI7 - Fix DEPEND/BDEPEND/etc - Remove empty/unused variable assignments - Parallel tests - Migrate .-in-inc "sed" to a "patch" - Add possible fix patch for bug #627058 Bug: https://bugs.gentoo.org/627058 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Crypt-RSA')
-rw-r--r--dev-perl/Crypt-RSA/Crypt-RSA-1.990.0-r2.ebuild35
-rw-r--r--dev-perl/Crypt-RSA/files/Crypt-RSA-1.99-no-dot-inc.patch24
-rw-r--r--dev-perl/Crypt-RSA/files/Crypt-RSA-1.99-test-segv.patch31
3 files changed, 90 insertions, 0 deletions
diff --git a/dev-perl/Crypt-RSA/Crypt-RSA-1.990.0-r2.ebuild b/dev-perl/Crypt-RSA/Crypt-RSA-1.990.0-r2.ebuild
new file mode 100644
index 000000000000..22791806cbe1
--- /dev/null
+++ b/dev-perl/Crypt-RSA/Crypt-RSA-1.990.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=VIPUL
+DIST_VERSION=1.99
+inherit perl-module
+
+DESCRIPTION="RSA public-key cryptosystem"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~x86 ~x86-solaris"
+
+RDEPEND="
+ >=dev-perl/Class-Loader-2.0.0
+ dev-perl/Convert-ASCII-Armour
+ dev-perl/Crypt-Blowfish
+ dev-perl/Crypt-CBC
+ >=dev-perl/Crypt-Primes-0.380.0
+ >=dev-perl/Crypt-Random-0.340.0
+ dev-perl/Data-Buffer
+ virtual/perl-Data-Dumper
+ dev-perl/Digest-MD2
+ virtual/perl-Digest-MD5
+ dev-perl/Digest-SHA1
+ >=dev-perl/Math-Pari-2.10.603
+ dev-perl/Sort-Versions
+ dev-perl/Tie-EncryptedHash"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.99-no-dot-inc.patch"
+ "${FILESDIR}/${PN}-1.99-test-segv.patch"
+)
diff --git a/dev-perl/Crypt-RSA/files/Crypt-RSA-1.99-no-dot-inc.patch b/dev-perl/Crypt-RSA/files/Crypt-RSA-1.99-no-dot-inc.patch
new file mode 100644
index 000000000000..f84cac6fbf19
--- /dev/null
+++ b/dev-perl/Crypt-RSA/files/Crypt-RSA-1.99-no-dot-inc.patch
@@ -0,0 +1,24 @@
+From 76ef0a65ae8b93da138c179e7e0c2995113825d9 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Thu, 2 Jul 2020 20:11:50 +1200
+Subject: Include '.' in @INC on perl 5.26+
+
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 95eb265..90f6da8 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -8,6 +8,7 @@
+ ##
+ ## $Id: Makefile.PL,v 1.12 2001/05/30 13:10:32 vipul Exp $
+
++use lib '.';
+ use inc::Module::Install;
+
+ name 'Crypt-RSA';
+--
+2.27.0
+
diff --git a/dev-perl/Crypt-RSA/files/Crypt-RSA-1.99-test-segv.patch b/dev-perl/Crypt-RSA/files/Crypt-RSA-1.99-test-segv.patch
new file mode 100644
index 000000000000..559e36830179
--- /dev/null
+++ b/dev-perl/Crypt-RSA/files/Crypt-RSA-1.99-test-segv.patch
@@ -0,0 +1,31 @@
+From 877c93686ad36d5dcc4a42b8bff5f3c5383e6514 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Thu, 2 Jul 2020 20:16:20 +1200
+Subject: Change load order of Convert::ASCII::Armour
+
+Which is reported to somehow fix segv's in t/11-wrapper.t
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=4877
+Bug: https://bugs.gentoo.org/627058
+---
+ lib/Crypt/RSA.pm | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/Crypt/RSA.pm b/lib/Crypt/RSA.pm
+index 5a3d3bc..072f0b4 100644
+--- a/lib/Crypt/RSA.pm
++++ b/lib/Crypt/RSA.pm
+@@ -15,9 +15,9 @@ use lib "$Bin/../../lib";
+ use strict;
+ use base 'Class::Loader';
+ use base 'Crypt::RSA::Errorhandler';
++use Convert::ASCII::Armour;
+ use Crypt::RSA::Key;
+ use Crypt::RSA::DataFormat qw(steak octet_len);
+-use Convert::ASCII::Armour;
+ use Carp;
+
+ $Crypt::RSA::VERSION = '1.99'; # change this elsewhere too!
+--
+2.27.0
+