summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Curses
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Curses')
-rw-r--r--dev-perl/Curses/Curses-1.280.0-r1.ebuild40
-rw-r--r--dev-perl/Curses/Curses-1.320.0.ebuild40
-rw-r--r--dev-perl/Curses/Manifest2
-rw-r--r--dev-perl/Curses/files/Curses-1.08-p5.8-fixes.diff32
-rw-r--r--dev-perl/Curses/metadata.xml16
5 files changed, 130 insertions, 0 deletions
diff --git a/dev-perl/Curses/Curses-1.280.0-r1.ebuild b/dev-perl/Curses/Curses-1.280.0-r1.ebuild
new file mode 100644
index 000000000000..a40b41b99289
--- /dev/null
+++ b/dev-perl/Curses/Curses-1.280.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=GIRAFFED
+MODULE_VERSION=1.28
+MODULE_A_EXT=tgz
+inherit perl-module
+
+DESCRIPTION="Curses interface modules for Perl"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~sparc-solaris ~x86-solaris"
+IUSE="unicode"
+
+DEPEND=">=sys-libs/ncurses-5[unicode?]"
+RDEPEND="${DEPEND}"
+
+SRC_TEST="do"
+
+my_curses_version() {
+ echo ncurses$(use unicode && echo w)
+}
+
+pkg_setup() {
+ myconf="${myconf} FORMS PANELS MENUS"
+ mydoc=HISTORY
+ export CURSES_LIBTYPE=$(my_curses_version)
+ export CURSES_LDFLAGS=$($(my_curses_version)5-config --libs)
+ export CURSES_CFLAGS=$( $(my_curses_version)5-config --cflags)
+}
+
+src_configure(){
+ perl-module_src_configure
+ if ! use unicode ; then
+ sed -i 's:<form.h>:"/usr/include/form.h":' "${S}"/c-config.h || die
+ fi
+}
diff --git a/dev-perl/Curses/Curses-1.320.0.ebuild b/dev-perl/Curses/Curses-1.320.0.ebuild
new file mode 100644
index 000000000000..9b6ff027d429
--- /dev/null
+++ b/dev-perl/Curses/Curses-1.320.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=GIRAFFED
+MODULE_VERSION=1.32
+MODULE_A_EXT=tgz
+inherit perl-module
+
+DESCRIPTION="Curses interface modules for Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-solaris ~x86-solaris"
+IUSE="+unicode"
+
+DEPEND=">=sys-libs/ncurses-5[unicode?]"
+RDEPEND="${DEPEND}"
+
+SRC_TEST="do"
+
+my_curses_version() {
+ echo ncurses$(use unicode && echo w)
+}
+
+pkg_setup() {
+ myconf="${myconf} FORMS PANELS MENUS"
+ mydoc=HISTORY
+ export CURSES_LIBTYPE=$(my_curses_version)
+ export CURSES_LDFLAGS=$($(my_curses_version)5-config --libs)
+ export CURSES_CFLAGS=$( $(my_curses_version)5-config --cflags)
+}
+
+src_configure(){
+ perl-module_src_configure
+ if ! use unicode ; then
+ sed -i 's:<form.h>:"/usr/include/form.h":' "${S}"/c-config.h || die
+ fi
+}
diff --git a/dev-perl/Curses/Manifest b/dev-perl/Curses/Manifest
new file mode 100644
index 000000000000..0d718e5fecba
--- /dev/null
+++ b/dev-perl/Curses/Manifest
@@ -0,0 +1,2 @@
+DIST Curses-1.28.tgz 127412 SHA256 613b73c4b6075b1550592812214e4fc0e2205d3afcf234e3fa90f208fb8de892 SHA512 75664b39174c9875f7f779801bddb08f89ace029ea99857b561e8f8eec167f6f9059a32bc51265145b84bca1316e6d2f90a576b280cfcc7e050225f28730dff2 WHIRLPOOL dbfb87c59a236fef47e5b03735c92d109b2b4bf4a35ae69691c465f832d4122b5d48663ae4707ec6d79e6e5f892f3fdf6991400605f996e712863b3fca1a14c0
+DIST Curses-1.32.tgz 134753 SHA256 5dba44fd7964806d9765e6692bc7eb8eb30aeced2740f28b9a4070a5d14ba650 SHA512 ecaa5cea2b544979229badc9f0d0ce84b385aa178ea0f821e6582865b3be63ea3d0cbc43651e2dc03334b796e5eab961c30e8f1637eec4af579843617e661562 WHIRLPOOL 37b548423430a79791659d40aa2d3d66546e0c49bbe8e1fc5c3798b30715ce1ed40343cdec70b3019a4d7c7d8adb37ca66fd8afa9f52d4b1e63774ac6a0c9b58
diff --git a/dev-perl/Curses/files/Curses-1.08-p5.8-fixes.diff b/dev-perl/Curses/files/Curses-1.08-p5.8-fixes.diff
new file mode 100644
index 000000000000..f661f80ff038
--- /dev/null
+++ b/dev-perl/Curses/files/Curses-1.08-p5.8-fixes.diff
@@ -0,0 +1,32 @@
+diff -Naurp CursesFun.c.old CursesFun.c
+--- CursesFun.c.old 2005-03-05 09:15:20.714006864 -0500
++++ CursesFun.c 2005-03-05 09:16:14.501829872 -0500
+@@ -1276,8 +1276,8 @@ XS(XS_Curses_newterm)
+ c_exactargs("newterm", items, 3);
+ {
+ char * type = ST(0) != &PL_sv_undef ? (char *)SvPV(ST(0),PL_na) : NULL;
+- FILE * outfd = IoIFP(sv_2io(ST(1)));
+- FILE * infd = IoIFP(sv_2io(ST(2)));
++ FILE * outfd = PerlIO_findFILE(IoIFP(sv_2io(ST(1))));
++ FILE * infd = PerlIO_findFILE(IoIFP(sv_2io(ST(2))));
+ SCREEN * ret = newterm(type, outfd, infd);
+
+ ST(0) = sv_newmortal();
+@@ -3450,7 +3450,7 @@ XS(XS_Curses_putwin)
+ c_exactargs("putwin", items, 2);
+ {
+ WINDOW *win = c_sv2window(ST(0), 0);
+- FILE * filep = IoIFP(sv_2io(ST(1)));
++ FILE * filep = PerlIO_findFILE(IoIFP(sv_2io(ST(1))));
+ int ret = putwin(win, filep);
+
+ ST(0) = sv_newmortal();
+@@ -3469,7 +3469,7 @@ XS(XS_Curses_getwin)
+ #ifdef C_GETWIN
+ c_exactargs("getwin", items, 1);
+ {
+- FILE * filep = IoIFP(sv_2io(ST(0)));
++ FILE * filep = PerlIO_findFILE(IoIFP(sv_2io(ST(0))));
+ WINDOW * ret = getwin(filep);
+
+ ST(0) = sv_newmortal();
diff --git a/dev-perl/Curses/metadata.xml b/dev-perl/Curses/metadata.xml
new file mode 100644
index 000000000000..c095bb01a13a
--- /dev/null
+++ b/dev-perl/Curses/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Curses</remote-id>
+ <remote-id type="cpan-module">Curses</remote-id>
+ <remote-id type="cpan-module">Curses::Field</remote-id>
+ <remote-id type="cpan-module">Curses::Form</remote-id>
+ <remote-id type="cpan-module">Curses::Item</remote-id>
+ <remote-id type="cpan-module">Curses::Menu</remote-id>
+ <remote-id type="cpan-module">Curses::Panel</remote-id>
+ <remote-id type="cpan-module">Curses::Screen</remote-id>
+ <remote-id type="cpan-module">Curses::Window</remote-id>
+ </upstream>
+</pkgmetadata>