summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-14 08:24:48 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-14 08:24:48 +1200
commitf05b1103375469bf074849103c6e3dc76122f84c (patch)
tree0707873c43a0fb31853263a82453380532c25efa /dev-perl/DBIx-ContextualFetch
parentdev-perl/DBIx-Class-UserStamp: -r bump for EAPI7 + fixes (diff)
downloadgentoo-f05b1103375469bf074849103c6e3dc76122f84c.tar.gz
gentoo-f05b1103375469bf074849103c6e3dc76122f84c.tar.bz2
gentoo-f05b1103375469bf074849103c6e3dc76122f84c.zip
dev-perl/DBIx-ContextualFetch: -r bump for EAPI7
- EAPI7 - Unconditionally patch out bad tests - Parallel testing Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/DBIx-ContextualFetch')
-rw-r--r--dev-perl/DBIx-ContextualFetch/DBIx-ContextualFetch-1.30.0-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/DBIx-ContextualFetch/DBIx-ContextualFetch-1.30.0-r2.ebuild b/dev-perl/DBIx-ContextualFetch/DBIx-ContextualFetch-1.30.0-r2.ebuild
new file mode 100644
index 000000000000..7a381f66bcd9
--- /dev/null
+++ b/dev-perl/DBIx-ContextualFetch/DBIx-ContextualFetch-1.30.0-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=TMTM
+DIST_VERSION=1.03
+inherit perl-module
+
+DESCRIPTION="Add contextual fetches to DBI"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-perl/DBI-1.37"
+BDEPEND="${RDEPEND}
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/DBD-SQLite
+ )
+"
+PERL_RM_FILES=(
+ t/pod.t
+ t/pod-coverage.t
+)