summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-15 07:29:40 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-15 07:31:18 +1200
commit0f85ff520667c6cf816b5fcb8d14a812e73a8d96 (patch)
tree9f5cc22da3a55e0f62f6ab400287af1bb0bb1850 /dev-perl/DBIx-SearchBuilder/DBIx-SearchBuilder-1.680.0.ebuild
parentx11-themes/adwaita-qt: amd64 stable, bug #726764 (diff)
downloadgentoo-0f85ff520667c6cf816b5fcb8d14a812e73a8d96.tar.gz
gentoo-0f85ff520667c6cf816b5fcb8d14a812e73a8d96.tar.bz2
gentoo-0f85ff520667c6cf816b5fcb8d14a812e73a8d96.zip
dev-perl/DBIx-SearchBuilder: Bump to version 1.680.0
- EAPI7 - Unconditionally remove bad tests - Rework patch for 'no-dot-inc' as this version fixes it, but only in Makefile.PL, the tests are still broken upstream. Upstream: - Avoid segfaults at disconnect with MariaDB 10.2+ and DBD::mysql ( not actually a bug in this code, but a guard against bugs in DBD::mysql / consuming code using an expired database connection, indirectly, through this module ) - Fix Makefile.PL for '.'-in-inc Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/DBIx-SearchBuilder/DBIx-SearchBuilder-1.680.0.ebuild')
-rw-r--r--dev-perl/DBIx-SearchBuilder/DBIx-SearchBuilder-1.680.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-perl/DBIx-SearchBuilder/DBIx-SearchBuilder-1.680.0.ebuild b/dev-perl/DBIx-SearchBuilder/DBIx-SearchBuilder-1.680.0.ebuild
new file mode 100644
index 000000000000..5a0f14dc3717
--- /dev/null
+++ b/dev-perl/DBIx-SearchBuilder/DBIx-SearchBuilder-1.680.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=BPS
+DIST_VERSION=1.68
+DIST_EXAMPLES=("ex/*")
+inherit perl-module
+
+DESCRIPTION="Encapsulate SQL queries and rows in simple Perl objects"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/Cache-Simple-TimedExpiry-0.210.0
+ dev-perl/Class-Accessor
+ >=dev-perl/Class-ReturnValue-0.400.0
+ dev-perl/Clone
+ dev-perl/DBI
+ dev-perl/DBIx-DBSchema
+ >=virtual/perl-Encode-1.990.0
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Want
+ >=dev-perl/capitalization-0.30.0
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.360.0
+ test? (
+ >=virtual/perl-Test-Simple-0.520.0
+ dev-perl/DBD-SQLite
+ virtual/perl-File-Temp
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.68-no-dot-inc.patch"
+)
+PERL_RM_FILES=(
+ t/pod.t
+)