summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-03-16 16:09:51 +1300
committerKent Fredric <kentnl@gentoo.org>2017-03-16 16:12:51 +1300
commit45d83edfeff3c5390a933dff158d313ef9b9d303 (patch)
tree75d7b646458c2de4358b2cd0ce630c5e97f44e87 /dev-perl/DateTime-Format-Strptime
parentdev-perl/DateTime-TimeZone: Bump to version 2.100.0 (masked) (diff)
downloadgentoo-45d83edfeff3c5390a933dff158d313ef9b9d303.tar.gz
gentoo-45d83edfeff3c5390a933dff158d313ef9b9d303.tar.bz2
gentoo-45d83edfeff3c5390a933dff158d313ef9b9d303.zip
dev-perl/DateTime-Format-Strptime: Bump to version 1.730.0 (masked)
Masked pending newer Test-Simple unmasking Keywords: - New dependencies cause keyword drops, removed: alpha, arm, hppa, ia64, ppc, ppc64, sparc Upstream: - Use Params::ValidationCompiler - Disabled word boundary checks by default, can be turned on with strict => 1 - Require lots of newer modules to fix bugs - format_datetime checks object isa DateTime Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-perl/DateTime-Format-Strptime')
-rw-r--r--dev-perl/DateTime-Format-Strptime/DateTime-Format-Strptime-1.730.0.ebuild37
-rw-r--r--dev-perl/DateTime-Format-Strptime/Manifest1
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/DateTime-Format-Strptime/DateTime-Format-Strptime-1.730.0.ebuild b/dev-perl/DateTime-Format-Strptime/DateTime-Format-Strptime-1.730.0.ebuild
new file mode 100644
index 000000000000..fa185e3c13da
--- /dev/null
+++ b/dev-perl/DateTime-Format-Strptime/DateTime-Format-Strptime-1.730.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=1.73
+inherit perl-module
+
+DESCRIPTION="Parse and Format DateTimes using Strptime"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-aix ~x86-fbsd ~x64-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/DateTime-1
+ >=dev-perl/DateTime-Locale-1.50.0
+ >=dev-perl/DateTime-TimeZone-2.90.0
+ virtual/perl-Exporter
+ >=dev-perl/Package-DeprecationManager-0.150.0
+ dev-perl/Params-ValidationCompiler
+ >=dev-perl/Specio-0.330.0
+ dev-perl/Try-Tiny
+ virtual/perl-parent
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.960.0
+ dev-perl/Test-Fatal
+ dev-perl/Test-Warnings
+ )
+"
diff --git a/dev-perl/DateTime-Format-Strptime/Manifest b/dev-perl/DateTime-Format-Strptime/Manifest
index c7e62b950f88..aa4ea60e5abf 100644
--- a/dev-perl/DateTime-Format-Strptime/Manifest
+++ b/dev-perl/DateTime-Format-Strptime/Manifest
@@ -2,3 +2,4 @@ DIST DateTime-Format-Strptime-1.56.tar.gz 36863 SHA256 2ff69d0f5a0359aab04e7276d
DIST DateTime-Format-Strptime-1.62.tar.gz 42268 SHA256 a03478bb832e20854f61a9aea05caf31c2c936cab759eb0b1f854ded4f0c8ae7 SHA512 beefc1aca04c21943b709d1b766b76e01209ba98173f930ea03fb6fffbda045eeacb7e52d0b8e4a4bc2f9d1b34b9d86006ceec0736a12d1487b51ca1e5c51e90 WHIRLPOOL 0366531e0d19b77988569db621c7259e479944dc7b0569edfbb9ba868bf24e60ab8ac2ea60c891f9eff6d61a0a3fa37a30269e79348d6674bfe879178479feef
DIST DateTime-Format-Strptime-1.68.tar.gz 103125 SHA256 d0f97e282b4de61390b5c3a498d3b9ee553f728c169c0845c6de02102d823929 SHA512 a1ed7236b7d48615bf8664286c1764b3e9a881f38e87e9dea493f957896ad786f46f99c0f4e5f54063e60f59c936fd2f61da638ac0512a09d38a87b6ffee8e9c WHIRLPOOL a0d74932d1c253e2443df8b2fc6e3505f3f44b43fe89ad011e2e2a6232c3efdf7b888f9648da350dca126faabe245fc1691200bb1a13272e1f7b55f1cfab2c26
DIST DateTime-Format-Strptime-1.70.tar.gz 105460 SHA256 ceead46b714c6baea3250b987078771f1ffbe217b501d6fc91ff3c5f2afbbc67 SHA512 a4f01f0032beb94d2bf359c2aab4050c2b321a6da236deec1ce198e88b657fb70b7328304f51fb12a9edf61035cb581c8a9a85c62a0ce8ff94c1ec5d22510d09 WHIRLPOOL 11094a65a2b63aa1f4e06ac5e83cf3a66ce3baefbc564472c3162c82ec20a606b96c00c8a21cb68cfed733c9bb615d7323e92ceb4f999e3f4680e7e405e4b500
+DIST DateTime-Format-Strptime-1.73.tar.gz 108454 SHA256 6d077806eb8581e5f28ffaff0bd2bb7a15114f9e745f61bd519405047765b2be SHA512 c259473e1120a9e40020cba2c7d008227521dbca0d2906878ee75e1ebc58e82760386bb32ebb1e987e68dfa4ce7f1e532dc4bfdf70467383425705e3f1c18d15 WHIRLPOOL 7238b9dec209da39f33a3fe2c6e34a0382eaa7787a5f25e9e09483d0ac8e84662ed4d763d00b351a10a9e274f3fdd85af10358ecfd578d124444a672020517ab