summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-11-11 16:45:18 +1300
committerKent Fredric <kentnl@gentoo.org>2016-11-11 16:45:56 +1300
commit91f4c905162f99491d8a2db9376e14b2155c6f98 (patch)
treebcd57c0f1eafeb4ee9bcc86da05e6872ee71e3bc /dev-perl/DateTime
parentdev-perl/DateTime-Locale: Bump to 1.30.0 (diff)
downloadgentoo-91f4c905162f99491d8a2db9376e14b2155c6f98.tar.gz
gentoo-91f4c905162f99491d8a2db9376e14b2155c6f98.tar.bz2
gentoo-91f4c905162f99491d8a2db9376e14b2155c6f98.zip
dev-perl/DateTime: Bump to 1.280.0
This is the last version we can bump to without needing to warp to Test2 infrastructure. Upstream: - Fix problems with floating point epoch handling - Added support for PERL_DATETIME_DEFAULT_TZ ENV flag - Migrated to EUMM - DateTime->from_object(DateTime::Infinite) now returns DateTime::Infinite - DateTime::Infinite returns system representation of positive/ negative infinity for methods like year(), month(), etc. - Support negative and scientific-notation values for from_epoch Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-perl/DateTime')
-rw-r--r--dev-perl/DateTime/DateTime-1.280.0.ebuild36
-rw-r--r--dev-perl/DateTime/Manifest1
-rw-r--r--dev-perl/DateTime/metadata.xml2
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-perl/DateTime/DateTime-1.280.0.ebuild b/dev-perl/DateTime/DateTime-1.280.0.ebuild
new file mode 100644
index 000000000000..5f5e013c8dd9
--- /dev/null
+++ b/dev-perl/DateTime/DateTime-1.280.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=1.28
+inherit perl-module
+
+DESCRIPTION="A date and time object"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/DateTime-Locale-0.410.0
+ >=dev-perl/DateTime-TimeZone-1.740.0
+ >=dev-perl/Params-Validate-1.30.0
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Try-Tiny
+ virtual/perl-XSLoader
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-Storable
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ >=dev-perl/Test-Warnings-0.5.0
+ )
+"
diff --git a/dev-perl/DateTime/Manifest b/dev-perl/DateTime/Manifest
index 77af81a63a55..759663c9b4e0 100644
--- a/dev-perl/DateTime/Manifest
+++ b/dev-perl/DateTime/Manifest
@@ -1,2 +1,3 @@
DIST DateTime-1.20.tar.gz 220697 SHA256 ac909ca4e26f2713940302ad1fd8068de0a6970416a5a88a812cceb155becb0d SHA512 b0374407683da3b68d0a127a2899deb8222f3bbd3e1f68481a000ca8c7fbde69bf4e43253b4cdd68f97b0a0ee7d8ed9d7a08fda8b5bf713b0f02ba722cd3aff9 WHIRLPOOL 0554f0d60fc57410aeecee8afa22997479bf9749eb1e46bd57f369a2ba98d8b4e8c06298304cd1bdec42879864440fe5e34f8df97def6188454caf14988e9143
DIST DateTime-1.21.tar.gz 221151 SHA256 a3a5840cae36d693b1371bd0f615aa8e3ab7f6cc25e06bff40c7010217d3f6b1 SHA512 256b49c6857c2eab4508ed1c1ddca0d88a32339c10334d70f95599d4d49934fe2fbc7689df334121c29abdb8eb0ebdf066183361224a5dbdce98fc1a216a721f WHIRLPOOL 73a277d680f6a806f54fd23d31d2bc34220e042e202d8df1d272c664f4171f3afbb34e2be8aef091bf4bd48ff9f4b775efa4810284a8e9081ac6bbde1af0e5ec
+DIST DateTime-1.28.tar.gz 229774 SHA256 781a25ab7dada202c917f6c5db06f6d9e6f03d5a395e91afab478ba074e75787 SHA512 cf2c883636073086101dc08596210e59af0cf301ae78e496358e6952f26104aa26c1fdc0784aa10e05ac0308a1ed7aef78a7682b803679481fa570f5de1c04a3 WHIRLPOOL 0eaeb2a30382f7952c7113bee2b8857f1e9409d1052f3031a55e72caf5ab18ec5827b062c4e57a540f917973235eff291cdf396de0ccd6e84a8cc4fdb64ea3dc
diff --git a/dev-perl/DateTime/metadata.xml b/dev-perl/DateTime/metadata.xml
index 3f99a4a8ca96..62d730f38f6a 100644
--- a/dev-perl/DateTime/metadata.xml
+++ b/dev-perl/DateTime/metadata.xml
@@ -14,5 +14,7 @@
<remote-id type="cpan-module">DateTime::Infinite::Future</remote-id>
<remote-id type="cpan-module">DateTime::Infinite::Past</remote-id>
<remote-id type="cpan-module">DateTime::LeapSecond</remote-id>
+ <remote-id type="cpan-module">DateTime::PP</remote-id>
+ <remote-id type="cpan-module">DateTime::PPExtra</remote-id>
</upstream>
</pkgmetadata>