summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-12-10 12:28:08 -0500
committerBrian Evans <grknight@gentoo.org>2019-12-10 12:38:07 -0500
commit3c07d3f4987c5b1a339dcf99400a097340fe6631 (patch)
tree652a5ee931018ce37ae9b2edfcd4079f69c2646f /dev-perl/File-Next
parentdev-ros/gazebo_plugins: fix build with opencv4 (diff)
downloadgentoo-3c07d3f4987c5b1a339dcf99400a097340fe6631.tar.gz
gentoo-3c07d3f4987c5b1a339dcf99400a097340fe6631.tar.bz2
gentoo-3c07d3f4987c5b1a339dcf99400a097340fe6631.zip
dev-perl/File-Next: Version bump to 1.180.0
Ack-by: dilfridge@gentoo.org Closes: https://bugs.gentoo.org/700684 Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-perl/File-Next')
-rw-r--r--dev-perl/File-Next/File-Next-1.180.0.ebuild29
-rw-r--r--dev-perl/File-Next/Manifest1
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/File-Next/File-Next-1.180.0.ebuild b/dev-perl/File-Next/File-Next-1.180.0.ebuild
new file mode 100644
index 000000000000..08bbf5784efe
--- /dev/null
+++ b/dev-perl/File-Next/File-Next-1.180.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PETDANCE
+DIST_VERSION=1.18
+inherit perl-module
+
+DESCRIPTION="File::Next is an iterator-based module for finding files"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="virtual/perl-File-Spec"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+RESTRICT="!test? ( test )"
+
+src_test() {
+ # Ugh, Upstream has tests that depend on tests ...
+ echo 'print qq[1..1\nok 1];' > "${S}/t/pod.t"
+ echo 'print qq[1..1\nok 1];' > "${S}/t/pod-coverage.t"
+ perl-module_src_test
+}
diff --git a/dev-perl/File-Next/Manifest b/dev-perl/File-Next/Manifest
index feb806987ec3..fa96f53321cd 100644
--- a/dev-perl/File-Next/Manifest
+++ b/dev-perl/File-Next/Manifest
@@ -1 +1,2 @@
DIST File-Next-1.16.tar.gz 17914 BLAKE2B 36e12dbc05830b622d4b77db803b63e2b1ef679a346634f13b40ab8d6b4a3f5ff2a43b6015930bc7e3fc3cd29829b8a0d76ce7ef2f3e1584699a9c70a23fd48d SHA512 42c812b8927a18e1f01758a2218f37f2079083117763b41adcee1eb4947b36b1379405707304b948fddd4640e2c34070f4dcd0f217fb60b7ba765efe98be8ad3
+DIST File-Next-1.18.tar.gz 18286 BLAKE2B bac27a198bb8c8fa887b09fcc9f7473191e236da62097fd93759b34c436676402da3e65c89e18eb30ffc6dae0fda3bc7b4b750c5483442af345b8e89ee3760d7 SHA512 951ad995b40ddda359a10ba2d7e19622059da03e7aaa3411e2e887633fbf7720554dc3f98ad581b245b2ffb51ea79f7c5eedecf6e943359eb407df0f9014e627