summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Gtk2-Notify
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Gtk2-Notify')
-rw-r--r--dev-perl/Gtk2-Notify/Gtk2-Notify-0.05-r1.ebuild32
-rw-r--r--dev-perl/Gtk2-Notify/Manifest1
-rw-r--r--dev-perl/Gtk2-Notify/files/Gtk2-Notify-0.05-libnotify.patch114
-rw-r--r--dev-perl/Gtk2-Notify/metadata.xml9
4 files changed, 156 insertions, 0 deletions
diff --git a/dev-perl/Gtk2-Notify/Gtk2-Notify-0.05-r1.ebuild b/dev-perl/Gtk2-Notify/Gtk2-Notify-0.05-r1.ebuild
new file mode 100644
index 000000000000..259c43665104
--- /dev/null
+++ b/dev-perl/Gtk2-Notify/Gtk2-Notify-0.05-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=FLORA
+
+inherit perl-module virtualx
+
+DESCRIPTION="A perl interface to the notification library"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="dev-perl/glib-perl
+ dev-perl/gtk2-perl
+ >=x11-libs/libnotify-0.7"
+DEPEND="${RDEPEND}
+ dev-perl/ExtUtils-Depends
+ dev-perl/extutils-pkgconfig
+ test? ( dev-perl/Test-Exception )"
+
+SRC_TEST="do"
+
+PATCHES=( "${FILESDIR}"/${P}-libnotify.patch )
+
+src_test() {
+ VIRTUALX_COMMAND="perl-module_src_test" virtualmake #416729
+}
diff --git a/dev-perl/Gtk2-Notify/Manifest b/dev-perl/Gtk2-Notify/Manifest
new file mode 100644
index 000000000000..dd08d562eb6d
--- /dev/null
+++ b/dev-perl/Gtk2-Notify/Manifest
@@ -0,0 +1 @@
+DIST Gtk2-Notify-0.05.tar.gz 60883 SHA256 88189ae68dfbd54615ad133df07e2ec8048d06d8b9586add1227d74eb2ebb047 SHA512 e6242c21f6a3345d990830798744c8dd3abf648c0110d395197fc74b185b68189f9fc90e0fc14717cc09505d67fbaf8f45c1b3fae65c873275537e55c9e35434 WHIRLPOOL 1b2af30bff792fc19257e34129bf19cdc3705693cc6f8992b5d712c2a2c39f46e7bc8e5d61cd4c5271cda97051f83976bebf4f7bf24b470c0e1b7c7aa29f788a
diff --git a/dev-perl/Gtk2-Notify/files/Gtk2-Notify-0.05-libnotify.patch b/dev-perl/Gtk2-Notify/files/Gtk2-Notify-0.05-libnotify.patch
new file mode 100644
index 000000000000..1e1ce9c094d3
--- /dev/null
+++ b/dev-perl/Gtk2-Notify/files/Gtk2-Notify-0.05-libnotify.patch
@@ -0,0 +1,114 @@
+http://bugs.gentoo.org/398699
+http://rt.cpan.org/Public/Bug/Display.html?id=67297
+http://pkgs.fedoraproject.org/gitweb/?p=perl-Gtk2-Notify.git;a=blob_plain;f=libnotify.patch;hb=HEAD
+
+--- t/notification.t
++++ t/notification.t
+@@ -2,20 +2,18 @@
+
+ use strict;
+ use warnings;
+-use Gtk2::TestHelper tests => 35;
++use Gtk2::TestHelper tests => 32;
+ use Test::Exception;
+ use Gtk2::Notify -init, $0;
+
+ ginterfaces_ok('Gtk2::Notify');
+
+-my $w = Gtk2::Window->new;
+-my $n = Gtk2::Notify->new('foo', 'bar', '', $w);
++my $n = Gtk2::Notify->new('foo', 'bar', '');
+
+ isa_ok($n, 'Gtk2::Notify');
+
+ my @methods = qw(
+ add_action
+- attach_to_widget
+ clear_actions
+ clear_hints
+ close
+@@ -46,16 +44,6 @@ lives_ok(sub {
+ }, 42);
+ }, 'add_action');
+
+-{
+- my $nw = Gtk2::Window->new;
+- lives_ok(sub {
+- $n->attach_to_widget($nw);
+- }, 'attach_to_widget');
+- lives_ok(sub {
+- $n->attach_to_widget($w);
+- }, 'attach_to_widget');
+-}
+-
+ lives_ok(sub {
+ $n->clear_actions;
+ }, 'clear_actions with existing actions');
+@@ -99,8 +87,6 @@ lives_ok(sub {
+ $n->close;
+ }, 'close before show');
+
+-$w->show_all;
+-
+ lives_ok(sub {
+ $n->show;
+ }, 'show');
+--- xs/Notify.xs
++++ xs/Notify.xs
+@@ -86,26 +86,12 @@ notify_get_server_info (class, OUTLIST c
+ MODULE = Gtk2::Notify PACKAGE = Gtk2::Notify PREFIX = notify_notification_
+
+ NotifyNotification *
+-notify_notification_new (class, summary, body=NULL, icon=NULL, attach=NULL)
++notify_notification_new (class, summary, body=NULL, icon=NULL)
+ const gchar *summary
+ const gchar *body
+ const gchar *icon
+- GtkWidget_ornull *attach
+ C_ARGS:
+- summary, body, icon, attach
+-
+-#if GTK_CHECK_VERSION (2, 9, 2)
+-
+-NotifyNotification *
+-notify_notification_new_with_status_icon (class, summary, body=NULL, icon=NULL, status_icon=NULL)
+- const gchar *summary
+- const gchar *body
+- const gchar *icon
+- GtkStatusIcon *status_icon
+- C_ARGS:
+- summary, body, icon, status_icon
+-
+-#endif
++ summary, body, icon
+
+ gboolean
+ notify_notification_update (notification, summary, message=NULL, icon=NULL)
+@@ -114,27 +100,6 @@ notify_notification_update (notification
+ const gchar *message
+ const gchar *icon
+
+-void
+-notify_notification_attach_to_widget (notification, attach)
+- NotifyNotification *notification
+- GtkWidget *attach
+-
+-#if GTK_CHECK_VERSION (2, 9, 2)
+-
+-void
+-notify_notification_attach_to_status_icon (notification, status_icon)
+- NotifyNotification *notification
+- GtkStatusIcon *status_icon
+-
+-#endif
+-
+-void
+-notify_notification_set_geometry_hints (notification, screen, x, y)
+- NotifyNotification *notification
+- GdkScreen *screen
+- gint x
+- gint y
+-
+ NO_OUTPUT gboolean
+ notify_notification_show (notification)
+ NotifyNotification *notification
diff --git a/dev-perl/Gtk2-Notify/metadata.xml b/dev-perl/Gtk2-Notify/metadata.xml
new file mode 100644
index 000000000000..c276f24f8902
--- /dev/null
+++ b/dev-perl/Gtk2-Notify/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Gtk2-Notify</remote-id>
+ <remote-id type="cpan-module">Gtk2::Notify</remote-id>
+ </upstream>
+</pkgmetadata>