summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-02 15:25:55 +0000
committerSam James <sam@gentoo.org>2022-07-02 15:32:11 +0000
commit10521e5ffe44b04493eddb1af5e762e7a3ead053 (patch)
tree42503c13af273fde9a20ea252b6c6cf69dd3524b /dev-perl/HTML-Mason
parentdev-perl/librg-utils-perl: drop 1.0.43-r1 (diff)
downloadgentoo-10521e5ffe44b04493eddb1af5e762e7a3ead053.tar.gz
gentoo-10521e5ffe44b04493eddb1af5e762e7a3ead053.tar.bz2
gentoo-10521e5ffe44b04493eddb1af5e762e7a3ead053.zip
dev-perl/HTML-Mason: update EAPI 6 -> 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/HTML-Mason')
-rw-r--r--dev-perl/HTML-Mason/HTML-Mason-1.590.0-r1.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-perl/HTML-Mason/HTML-Mason-1.590.0-r1.ebuild b/dev-perl/HTML-Mason/HTML-Mason-1.590.0-r1.ebuild
new file mode 100644
index 000000000000..7aea94b71506
--- /dev/null
+++ b/dev-perl/HTML-Mason/HTML-Mason-1.590.0-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=1.59
+inherit depend.apache perl-module
+
+DESCRIPTION="A HTML development and delivery Perl Module"
+HOMEPAGE="http://www.masonhq.com/ https://metacpan.org/release/HTML-Mason"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="modperl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !modperl? ( >=dev-perl/CGI-2.460.0 )
+ modperl? (
+ www-apache/libapreq2
+ >=www-apache/mod_perl-2
+ )
+ >=dev-perl/Cache-Cache-1
+ >=dev-perl/Class-Container-0.70.0
+ >=dev-perl/Exception-Class-1.150.0
+ virtual/perl-File-Spec
+ dev-perl/HTML-Parser
+ >=dev-perl/Log-Any-0.80.0
+ >=dev-perl/Params-Validate-0.70.0
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ dev-perl/Test-Deep
+ )
+"
+
+want_apache2 modperl
+
+mydoc="CREDITS UPGRADE"
+myconf="--noprompts"
+
+pkg_setup() {
+ depend.apache_pkg_setup modperl
+ perl_set_version
+}
+
+src_prepare() {
+ # Note about new modperl use flag
+ if use !modperl ; then
+ ewarn "HTML-Mason will only install with modperl support"
+ ewarn "if the use flag modperl is enabled."
+ fi
+ # rendhalver - needed to set an env var for the build script so it finds our apache.
+ export APACHE="${APACHE_BIN}"
+ perl-module_src_prepare
+}
+
+src_install() {
+ perl-module_src_install
+ mv "${ED}"/usr/bin/convert* "${ED}"/usr/share/doc/${PF} || die
+}