summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-02-04 23:38:40 +1300
committerKent Fredric <kentnl@gentoo.org>2020-02-04 23:40:09 +1300
commit30d6e9e94eb2a0b2a72778d9fcda422678eed08e (patch)
tree20208b4a5cf063aed24ff2aa866e1b747511dee4 /dev-perl/IO-Compress-Brotli
parentprofiles: Mask app-text/pybookreader for removal (diff)
downloadgentoo-30d6e9e94eb2a0b2a72778d9fcda422678eed08e.tar.gz
gentoo-30d6e9e94eb2a0b2a72778d9fcda422678eed08e.tar.bz2
gentoo-30d6e9e94eb2a0b2a72778d9fcda422678eed08e.zip
dev-perl/IO-Compress-Brotli: Add w/ version 0.4.1
Required as a dependency for bumping www-apps/webdavcgi to 1.1.2 Change suggested by Christian Affolter, but reworked from scratch to incorporate unbundling of brotli, and to employ proper versions, and EAPI7. Bug: https://bugs.gentoo.org/658470 Bug: https://github.com/gentoo/gentoo/pull/10826 Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/IO-Compress-Brotli')
-rw-r--r--dev-perl/IO-Compress-Brotli/IO-Compress-Brotli-0.4.1.ebuild28
-rw-r--r--dev-perl/IO-Compress-Brotli/Manifest1
-rw-r--r--dev-perl/IO-Compress-Brotli/files/IO-Compress-Brotli-0.004001-unbundle.patch49
-rw-r--r--dev-perl/IO-Compress-Brotli/metadata.xml13
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-perl/IO-Compress-Brotli/IO-Compress-Brotli-0.4.1.ebuild b/dev-perl/IO-Compress-Brotli/IO-Compress-Brotli-0.4.1.ebuild
new file mode 100644
index 000000000000..812152ba4882
--- /dev/null
+++ b/dev-perl/IO-Compress-Brotli/IO-Compress-Brotli-0.4.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MGV
+DIST_VERSION=0.004001
+inherit perl-module
+
+DESCRIPTION="Read/write Brotli buffers/streams"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-perl/File-Slurper
+ virtual/perl-Getopt-Long
+ virtual/perl-Time-HiRes
+ app-arch/brotli:=
+"
+DEPEND="
+ app-arch/brotli:=
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-${DIST_VERSION}-unbundle.patch"
+)
diff --git a/dev-perl/IO-Compress-Brotli/Manifest b/dev-perl/IO-Compress-Brotli/Manifest
new file mode 100644
index 000000000000..fd5e5bbefcb6
--- /dev/null
+++ b/dev-perl/IO-Compress-Brotli/Manifest
@@ -0,0 +1 @@
+DIST IO-Compress-Brotli-0.004001.tar.gz 7674244 BLAKE2B b3c4d6a1101429fc47f345f0ba119e5196873a0e5d368b31d02f76ca2a0ac269ed4c9c82972de527052b55e73a2a4724ebf4f644c23c383304082413b512dfad SHA512 7cc198ecef15c912d8b62e6851935c433159e7f3680f2034949c032d23827f5a5720dd02b77b89b60d43b0a2a7df059c9e76c8f4e44993c28630624f0e17a377
diff --git a/dev-perl/IO-Compress-Brotli/files/IO-Compress-Brotli-0.004001-unbundle.patch b/dev-perl/IO-Compress-Brotli/files/IO-Compress-Brotli-0.004001-unbundle.patch
new file mode 100644
index 000000000000..84205c548bd1
--- /dev/null
+++ b/dev-perl/IO-Compress-Brotli/files/IO-Compress-Brotli-0.004001-unbundle.patch
@@ -0,0 +1,49 @@
+From 59541041bc3b39e8539fd12a8e584a63040ad7a5 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Tue, 4 Feb 2020 23:17:49 +1300
+Subject: Disable using bundled brotli
+
+---
+ Makefile.PL | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 0c59c05..b10234d 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,6 +1,8 @@
+ use 5.014000;
+ use ExtUtils::MakeMaker;
+
++my $bundled = $ENV{IO_COMPRESS_BROTLI_BUNDLED} || 0;
++
+ WriteMakefile(
+ NAME => 'IO::Compress::Brotli',
+ VERSION_FROM => 'lib/IO/Compress/Brotli.pm',
+@@ -16,9 +18,13 @@ WriteMakefile(
+ 'Time::HiRes' => '0',
+ },
+ BUILD_REQUIRES => {},
++ ( $bundled ) ? (
+ INC => '-Ibrotli/c/include',
+ MYEXTLIB => 'brotli/libbrotli$(LIB_EXT)',
+ clean => { FILES => 'brotli/libbrotli$(LIB_EXT)' },
++ ) : (
++ LIBS => ['-lbrotlienc -lbrotlidec'],
++ ),
+ META_ADD => {
+ dynamic_config => 0,
+ resources => {
+@@ -27,7 +33,9 @@ WriteMakefile(
+ }
+ );
+
++
+ sub MY::postamble {
++ return '' unless $bundled;
+ '
+ $(MYEXTLIB): brotli/Makefile
+ cd brotli && CFLAGS=-fPIC `which gmake || echo $(MAKE)` lib
+--
+2.25.0
+
diff --git a/dev-perl/IO-Compress-Brotli/metadata.xml b/dev-perl/IO-Compress-Brotli/metadata.xml
new file mode 100644
index 000000000000..b55083f195d7
--- /dev/null
+++ b/dev-perl/IO-Compress-Brotli/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">IO-Compress-Brotli</remote-id>
+ <remote-id type="cpan-module">IO::Compress::Brotli</remote-id>
+ <remote-id type="cpan-module">IO::Uncompress::Brotli</remote-id>
+ </upstream>
+</pkgmetadata>