summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-03-19 01:04:35 +1300
committerKent Fredric <kentnl@gentoo.org>2017-03-19 01:05:17 +1300
commitff8c12006085634961d1f53620506716055ce12e (patch)
tree20cb30072e5f2da4a97ddf53897bdbd8711de002 /dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.390.0.ebuild
parentdev-perl/libwww-perl: Bump to version 6.240.0 (diff)
downloadgentoo-ff8c12006085634961d1f53620506716055ce12e.tar.gz
gentoo-ff8c12006085634961d1f53620506716055ce12e.tar.bz2
gentoo-ff8c12006085634961d1f53620506716055ce12e.zip
dev-perl/Mail-IMAPClient: Bump to version 3.390.0
- Remove bad POD tests - Add USE=examples Upstream: - Fix uninitialized value in fetch_hash - Improve error reporting when TLS connections fail - new doretry option to _imap_command - Don't retry the "DONE" command Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.390.0.ebuild')
-rw-r--r--dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.390.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.390.0.ebuild b/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.390.0.ebuild
new file mode 100644
index 000000000000..95638104d953
--- /dev/null
+++ b/dev-perl/Mail-IMAPClient/Mail-IMAPClient-3.390.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PLOBBES
+DIST_VERSION=3.39
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="IMAP client module for Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test ntlm md5 ssl zlib"
+
+PATCHES=(
+ "${FILESDIR}/${DIST_VERSION}-makefilepl.patch"
+)
+PERL_RM_FILES=(
+ "t/quota.t" # Requires imap server config in test.txt
+ "t/basic.t"
+ "t/pod.t" # Bad author test
+)
+# IO::File, IO::Select, IO::Socket, IO::Socket::INET -> perl-IO
+# Digest::HMAC_MD5 -> Digest-HMAC
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-File-Temp
+ >=virtual/perl-IO-1.260.0
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-MIME-Base64
+ >=dev-perl/Parse-RecDescent-1.967.9
+ ntlm? ( dev-perl/Authen-NTLM )
+ md5? (
+ dev-perl/Authen-SASL
+ dev-perl/Digest-HMAC
+ virtual/perl-Digest-MD5
+ )
+ ssl? ( dev-perl/IO-Socket-SSL )
+ zlib? ( virtual/perl-IO-Compress )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"