summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-02-22 20:57:16 +1300
committerKent Fredric <kentfredric@gmail.com>2016-02-27 21:39:56 +1300
commitfc8a0bdd8f691090d830542c8b7e019af09a8279 (patch)
tree65c7649567976f9673c9897576cf5d4f63deed15 /dev-perl/Math-ModInt
parentdev-perl/Math-GMP: Bump to version 2.110.0 (diff)
downloadgentoo-fc8a0bdd8f691090d830542c8b7e019af09a8279.tar.gz
gentoo-fc8a0bdd8f691090d830542c8b7e019af09a8279.tar.bz2
gentoo-fc8a0bdd8f691090d830542c8b7e019af09a8279.zip
dev-perl/Math-ModInt: Bump to version 0.11.0
- EAPI - Fixup license - Cleanup tests Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-perl/Math-ModInt')
-rw-r--r--dev-perl/Math-ModInt/Manifest1
-rw-r--r--dev-perl/Math-ModInt/Math-ModInt-0.11.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/Math-ModInt/Manifest b/dev-perl/Math-ModInt/Manifest
index 67d872af6c08..23fe0a209393 100644
--- a/dev-perl/Math-ModInt/Manifest
+++ b/dev-perl/Math-ModInt/Manifest
@@ -1 +1,2 @@
DIST Math-ModInt-0.007.tar.gz 37509 SHA256 961744ac23539c04e29e245ce5e2f1abdd4354b9afc6833c4f4893aa412115dd SHA512 84789d48b55e130541e6564ccde95f45da3d8553da7c5cef073d1068910a72d33da1ac2ce3dc22a8cff868dfee62f35416a44bee5773be74eccccce96548b8e5 WHIRLPOOL e7481c54207755f1657a5adaf39b77e4eabea30414d80b5b13f1d7901cd11617043ba13ff21944052c0441df97d0b629da725754cdada7a1c4a4f77df8a4fea6
+DIST Math-ModInt-0.011.tar.gz 40189 SHA256 a19eb1deca4903de50c7214898105e9cab46475c97182da2cddb9ff083301ed7 SHA512 c6a1b90e07dc6a4b620b0db63eaa205dad19ba3c96e8031f93d1c3fca137d5430e3c1e88d3bad9d3f6d64600bee4deb9c13e13fdad410c76f9c10732fd2495e0 WHIRLPOOL 1d1e9fd222fb1f539b9563b5400b6c1898a5fdbe6604ef167438df4efa2ce92a61c3b3defb3918e3a0e446001e4b36c2cb29c62553e5936caad86081100741bc
diff --git a/dev-perl/Math-ModInt/Math-ModInt-0.11.0.ebuild b/dev-perl/Math-ModInt/Math-ModInt-0.11.0.ebuild
new file mode 100644
index 000000000000..8c24eaee6a58
--- /dev/null
+++ b/dev-perl/Math-ModInt/Math-ModInt-0.11.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=MHASCH
+DIST_VERSION=0.011
+
+inherit perl-module
+
+DESCRIPTION="modular integer arithmetic"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="minimal test"
+
+PERL_RM_FILES=(
+ "t/90_pod.t"
+ "t/91_pod_cover_cp.t"
+ "t/92_consistency.t"
+ "t/93_examples.t"
+ "t/95_versions.t"
+ "t/99_signature.t"
+)
+RDEPEND="
+ virtual/perl-Carp
+ >=virtual/perl-Math-BigInt-1.991.0
+ !minimal? (
+ dev-perl/Math-BigInt-GMP
+ virtual/perl-Math-BigRat
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Test
+ virtual/perl-Test-Simple
+ )
+"