summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-08-04 08:43:19 +1200
committerKent Fredric <kentnl@gentoo.org>2016-08-04 09:00:01 +1200
commiteb7b2a773c813c231325ade6cb952541576795ed (patch)
tree723efe1a48147e6d48607bca9e081d3233676131 /dev-perl/Module-Runtime/Module-Runtime-0.14.0.ebuild
parentdev-java/javax-mail: new ebuild (diff)
downloadgentoo-eb7b2a773c813c231325ade6cb952541576795ed.tar.gz
gentoo-eb7b2a773c813c231325ade6cb952541576795ed.tar.bz2
gentoo-eb7b2a773c813c231325ade6cb952541576795ed.zip
dev-perl/Module-Runtime: Remove Pod Authortests.
This removes the various (optional) POD tests and the related dependencies as they can never serve an end user any benefit about reporting their dist broken. All it can do is introduce more things that break, and more dependencies for stabilization. Module::Runtime is hence the most used package that does this still. Incidentally, removing these dependencies unbreaks the dependecy subgraph on m68k Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/Module-Runtime/Module-Runtime-0.14.0.ebuild')
-rw-r--r--dev-perl/Module-Runtime/Module-Runtime-0.14.0.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-perl/Module-Runtime/Module-Runtime-0.14.0.ebuild b/dev-perl/Module-Runtime/Module-Runtime-0.14.0.ebuild
index 86c736fc3b55..c0f4c134768b 100644
--- a/dev-perl/Module-Runtime/Module-Runtime-0.14.0.ebuild
+++ b/dev-perl/Module-Runtime/Module-Runtime-0.14.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -19,9 +19,12 @@ DEPEND="${RDEPEND}
dev-perl/Module-Build
test? (
virtual/perl-Test-Simple
- dev-perl/Test-Pod
- dev-perl/Test-Pod-Coverage
)
"
SRC_TEST="do"
+
+src_test() {
+ perl_rm_files t/pod_cvg.t t/pod_syn.t
+ perl-module_src_test
+}