summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-05-30 07:17:14 +1200
committerKent Fredric <kentnl@gentoo.org>2017-05-30 07:17:28 +1200
commit9b15463555995d6da01cb6eec833f0361d48afcd (patch)
tree8d9f9528988e894568ffea09ba0df835d3100540 /dev-perl/Mojolicious/Mojolicious-7.310.0.ebuild
parentdev-libs/glib: Update license to LGPL-2.1+ (diff)
downloadgentoo-9b15463555995d6da01cb6eec833f0361d48afcd.tar.gz
gentoo-9b15463555995d6da01cb6eec833f0361d48afcd.tar.bz2
gentoo-9b15463555995d6da01cb6eec833f0361d48afcd.zip
dev-perl/Mojolicious: Bump to version 7.310.0
Upstream: - Remove many previously advertised deprecated functions/interfaces - Fix app generator command where config file name was not based on application name Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Mojolicious/Mojolicious-7.310.0.ebuild')
-rw-r--r--dev-perl/Mojolicious/Mojolicious-7.310.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Mojolicious/Mojolicious-7.310.0.ebuild b/dev-perl/Mojolicious/Mojolicious-7.310.0.ebuild
new file mode 100644
index 000000000000..64f7302560e1
--- /dev/null
+++ b/dev-perl/Mojolicious/Mojolicious-7.310.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SRI
+DIST_VERSION=7.31
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Real-time web framework"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test minimal"
+
+RDEPEND="
+ !minimal? (
+ >=dev-perl/EV-4.0.0
+ )
+ >=virtual/perl-IO-Socket-IP-0.370.0
+ >=virtual/perl-JSON-PP-2.271.30
+ >=virtual/perl-Pod-Simple-3.90.0
+ >=virtual/perl-Time-Local-1.200.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+src_test() {
+ perl_rm_files t/pod{,_coverage}.t
+ perl-module_src_test
+}