summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-06-02 13:04:26 +1200
committerKent Fredric <kentnl@gentoo.org>2017-06-02 13:04:26 +1200
commit3fa48413c070786a4573bb8b184103fef7c75fb9 (patch)
tree11551db61af35aed442c2c5bae03c75fcb8e30a0 /dev-perl/Mojolicious/Mojolicious-7.320.0.ebuild
parentmedia-libs/phonon-vlc: Drop old (diff)
downloadgentoo-3fa48413c070786a4573bb8b184103fef7c75fb9.tar.gz
gentoo-3fa48413c070786a4573bb8b184103fef7c75fb9.tar.bz2
gentoo-3fa48413c070786a4573bb8b184103fef7c75fb9.zip
dev-perl/Mojolicious: Bump to version 7.320.0
Upstream: - get command now supports -f - get command can now pass request data by stdin redirection - fix memory leak breaking timeout in TLS handshake Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Mojolicious/Mojolicious-7.320.0.ebuild')
-rw-r--r--dev-perl/Mojolicious/Mojolicious-7.320.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Mojolicious/Mojolicious-7.320.0.ebuild b/dev-perl/Mojolicious/Mojolicious-7.320.0.ebuild
new file mode 100644
index 000000000000..55270db5eacb
--- /dev/null
+++ b/dev-perl/Mojolicious/Mojolicious-7.320.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SRI
+DIST_VERSION=7.32
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Real-time web framework"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test minimal"
+
+RDEPEND="
+ !minimal? (
+ >=dev-perl/EV-4.0.0
+ )
+ >=virtual/perl-IO-Socket-IP-0.370.0
+ >=virtual/perl-JSON-PP-2.271.30
+ >=virtual/perl-Pod-Simple-3.90.0
+ >=virtual/perl-Time-Local-1.200.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+src_test() {
+ perl_rm_files t/pod{,_coverage}.t
+ perl-module_src_test
+}