summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel <dilfridge@gentoo.org>2017-06-28 20:40:42 +0200
committerAndreas K. Huettel <dilfridge@gentoo.org>2017-06-28 20:40:42 +0200
commit898ab5150445f6d5867a2e1e3b2dada75ea7d63f (patch)
tree14ab2766a598bc22b2c7ce22176a70f5fa2221db /dev-perl/Moose-Autobox/Moose-Autobox-0.160.0.ebuild
parentdev-python/ginga: version bump (diff)
downloadgentoo-898ab5150445f6d5867a2e1e3b2dada75ea7d63f.tar.gz
gentoo-898ab5150445f6d5867a2e1e3b2dada75ea7d63f.tar.bz2
gentoo-898ab5150445f6d5867a2e1e3b2dada75ea7d63f.zip
dev-perl/Moose-Autobox: New package, needed for Dist::Zilla::Plugin::RPM
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Moose-Autobox/Moose-Autobox-0.160.0.ebuild')
-rw-r--r--dev-perl/Moose-Autobox/Moose-Autobox-0.160.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Moose-Autobox/Moose-Autobox-0.160.0.ebuild b/dev-perl/Moose-Autobox/Moose-Autobox-0.160.0.ebuild
new file mode 100644
index 000000000000..caba919384bf
--- /dev/null
+++ b/dev-perl/Moose-Autobox/Moose-Autobox-0.160.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.16
+inherit perl-module
+
+DESCRIPTION="Autoboxed wrappers for Native Perl datatypes"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Data-Dumper
+ >=dev-perl/List-MoreUtils-0.70.0
+ >=dev-perl/Moose-0.420.0
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Syntax-Keyword-Junction
+ >=dev-perl/autobox-2.230.0
+ dev-perl/namespace-autoclean
+ virtual/perl-parent
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.34.0
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-Module-Metadata
+ dev-perl/Test-Exception
+ virtual/perl-Test-Simple
+ )
+"