summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Net-SMTP-SSL
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Net-SMTP-SSL')
-rw-r--r--dev-perl/Net-SMTP-SSL/Manifest2
-rw-r--r--dev-perl/Net-SMTP-SSL/Net-SMTP-SSL-1.10.0-r1.ebuild21
-rw-r--r--dev-perl/Net-SMTP-SSL/Net-SMTP-SSL-1.30.0.ebuild26
-rw-r--r--dev-perl/Net-SMTP-SSL/metadata.xml9
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-perl/Net-SMTP-SSL/Manifest b/dev-perl/Net-SMTP-SSL/Manifest
new file mode 100644
index 000000000000..353b523de4d1
--- /dev/null
+++ b/dev-perl/Net-SMTP-SSL/Manifest
@@ -0,0 +1,2 @@
+DIST Net-SMTP-SSL-1.01.tar.gz 1806 SHA256 13599c46bc7ce47fc151ace89d0625294b62154c3a20c7ff7e7614d1f2ee6289 SHA512 7d078830d088b18a7493820800e01743da4d771e8fb5f68bd5d2a6b035f4e40729adb7e5878cdd9a1a192a0c4e523a1c170e8733e30516804b16bc79d50e31ad WHIRLPOOL 3822093a14d344d36681d4acb387990507e317fa6675eb168050b3ca7b956612624965965b8a80760702726ada4879517d73db91036ba749134dfd5d83865cf4
+DIST Net-SMTP-SSL-1.03.tar.gz 2271 SHA256 305d0fdd74bb7339d1928e738b247262c0f708149781c5771583b71d5625c917 SHA512 71e766274745893cb6eddc91a4b24d7b538051974a2cd93d4abd8447daec72907b482edb25e628cfa480c99af935568c4765e85ddfc951e0ec9b2de25c366bc8 WHIRLPOOL 3f16396edcfe95abe7ab9313d8067fec1508bdbabe26d0325a50cc7f1d8cb6d8736d55af77be662affa2e29695c6ab6b3a92d74b681f03044696913151592404
diff --git a/dev-perl/Net-SMTP-SSL/Net-SMTP-SSL-1.10.0-r1.ebuild b/dev-perl/Net-SMTP-SSL/Net-SMTP-SSL-1.10.0-r1.ebuild
new file mode 100644
index 000000000000..cd1cf1379a16
--- /dev/null
+++ b/dev-perl/Net-SMTP-SSL/Net-SMTP-SSL-1.10.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=CWEST
+MODULE_VERSION=1.01
+inherit perl-module
+
+DESCRIPTION="SSL support for Net::SMTP"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="virtual/perl-libnet
+ dev-perl/IO-Socket-SSL"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do"
diff --git a/dev-perl/Net-SMTP-SSL/Net-SMTP-SSL-1.30.0.ebuild b/dev-perl/Net-SMTP-SSL/Net-SMTP-SSL-1.30.0.ebuild
new file mode 100644
index 000000000000..fc0841d9a448
--- /dev/null
+++ b/dev-perl/Net-SMTP-SSL/Net-SMTP-SSL-1.30.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=RJBS
+MODULE_VERSION=1.03
+inherit perl-module
+
+DESCRIPTION="SSL support for Net::SMTP"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-libnet
+ dev-perl/IO-Socket-SSL
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Net-SMTP-SSL/metadata.xml b/dev-perl/Net-SMTP-SSL/metadata.xml
new file mode 100644
index 000000000000..91ca28d5b125
--- /dev/null
+++ b/dev-perl/Net-SMTP-SSL/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Net-SMTP-SSL</remote-id>
+ <remote-id type="cpan-module">Net::SMTP::SSL</remote-id>
+ </upstream>
+</pkgmetadata>