summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-03-05 12:17:42 +1300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-05 21:32:32 +0100
commit87199cba91b708d238c7432fcb96a95268ec9607 (patch)
treec667715c31b2b4c2c208c452d3cfed3aa739aad3 /dev-perl/Net-SSLeay
parentdev-perl/Net-SSH2: Bump to version 0.580.0 (diff)
downloadgentoo-87199cba91b708d238c7432fcb96a95268ec9607.tar.gz
gentoo-87199cba91b708d238c7432fcb96a95268ec9607.tar.bz2
gentoo-87199cba91b708d238c7432fcb96a95268ec9607.zip
dev-perl/Net-SSLeay: Bump to version 1.720.0
- EAPI6 - Better DESCRIPTION - Tests enabled - Test deps added - Bad tests nuked - Tests minimalised where possible - 'examples' now optionally installed Upstream: - Bug fixes mostly Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-perl/Net-SSLeay')
-rw-r--r--dev-perl/Net-SSLeay/Manifest1
-rw-r--r--dev-perl/Net-SSLeay/Net-SSLeay-1.720.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-perl/Net-SSLeay/Manifest b/dev-perl/Net-SSLeay/Manifest
index 07e5a753d84f..cdc6c260dfa1 100644
--- a/dev-perl/Net-SSLeay/Manifest
+++ b/dev-perl/Net-SSLeay/Manifest
@@ -1 +1,2 @@
DIST Net-SSLeay-1.65.tar.gz 384413 SHA256 2fb1371120b85f018944d95736c107163f04ba56b6029c0709a2c3d6247b9c06 SHA512 e347ac7cc5ee22b9785953a5318d35fa3a2d5a21a2e726f49c74621d2dad9ea68373e208068dcd60d8a8d5ab027ae6e32fc0b671995d1645a14c2934eb5a884f WHIRLPOOL 15f38b5a026734f7a074b290979f3e346dfea125d02d8f63e7f5c163de7a4514456d3948ade61b74a53173e27aa221b9142736a98b9d6631c61f0239e6f0833b
+DIST Net-SSLeay-1.72.tar.gz 386011 SHA256 1baac39f0f12cee515d8bec633175bb5916ca542e5356e26420437bd6195d2f4 SHA512 33d8355af22bf76da21a6fc1f336970c6baf5a4595cd445a986bfd2de6ae4fac479d63a97d54c4cb2c9f3f1a7024c893ad0961be419adb6c51e0916829b53a88 WHIRLPOOL 13bceb86968209ae257d8144f4fc11ba9c39fe201cd9799b0135160c5b2ba17831ba35bc608739a2051a93516d4fa39738ec4d5737f2d824eb082fe25dd37a83
diff --git a/dev-perl/Net-SSLeay/Net-SSLeay-1.720.0.ebuild b/dev-perl/Net-SSLeay/Net-SSLeay-1.720.0.ebuild
new file mode 100644
index 000000000000..fb93cb8b0263
--- /dev/null
+++ b/dev-perl/Net-SSLeay/Net-SSLeay-1.720.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=MIKEM
+DIST_VERSION=1.72
+inherit multilib perl-module
+
+DESCRIPTION="Perl extension for using OpenSSL"
+
+LICENSE="openssl"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="libressl test minimal examples"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ virtual/perl-MIME-Base64
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ !minimal? (
+ dev-perl/Test-Exception
+ dev-perl/Test-Warn
+ dev-perl/Test-NoWarnings
+ )
+ virtual/perl-Test-Simple
+ )
+"
+export OPTIMIZE="$CFLAGS"
+export OPENSSL_PREFIX=${EPREFIX}/usr
+
+src_prepare() {
+ sed -i \
+ -e "/\$opts->{optimize} = '-O2 -g';/d" \
+ -e "s,\"\$prefix/lib\",\"\$prefix/$(get_libdir)\"," \
+ inc/Module/Install/PRIVATE/Net/SSLeay.pm || die
+ if use test; then
+ perl_rm_files 't/local/01_pod.t' 't/local/02_pod_coverage.t' 't/local/kwalitee.t'
+ fi
+ perl-module_src_prepare
+}
+src_install() {
+ perl-module_src_install
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}