summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-09-07 20:29:13 +1200
committerKent Fredric <kentnl@gentoo.org>2018-09-07 22:02:13 +1200
commit166bc76dbefd657f31b94c3e677c269e841d320e (patch)
tree6153b0a29e35afbac2dda4c48d5f3b86093c7445 /dev-perl/Number-WithError
parentdev-perl/Test-LectroTest: Add w/ version 0.500.100 (diff)
downloadgentoo-166bc76dbefd657f31b94c3e677c269e841d320e.tar.gz
gentoo-166bc76dbefd657f31b94c3e677c269e841d320e.tar.bz2
gentoo-166bc76dbefd657f31b94c3e677c269e841d320e.zip
dev-perl/Number-WithError: Add w/ version 1.10.0
Required by dev-perl/Archive-Tar-Wrapper via: -> dev-perl/Dumbbench Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-perl/Number-WithError')
-rw-r--r--dev-perl/Number-WithError/Manifest1
-rw-r--r--dev-perl/Number-WithError/Number-WithError-1.10.0.ebuild33
-rw-r--r--dev-perl/Number-WithError/files/Number-WithError-1.01-no-dot-inc.patch24
-rw-r--r--dev-perl/Number-WithError/metadata.xml12
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-perl/Number-WithError/Manifest b/dev-perl/Number-WithError/Manifest
new file mode 100644
index 000000000000..4d0106e898f6
--- /dev/null
+++ b/dev-perl/Number-WithError/Manifest
@@ -0,0 +1 @@
+DIST Number-WithError-1.01.tar.gz 38949 BLAKE2B 5ec7588f881bd46d329456c56a9b20455ec6d074e6f7531f9a039a7a9af5f121d21d17d9ea7b6bc2db42de2040961bd72d748ffab077816b62b5d9b8e910aaf7 SHA512 8d573801fa6c82b1e1578035f34d3208abc11cdd300563b21ae5a1f229f651e9f0b3f3c277da632ce3f583b86e99918ac0b5498ad3727a19e4d100b7e00df93b
diff --git a/dev-perl/Number-WithError/Number-WithError-1.10.0.ebuild b/dev-perl/Number-WithError/Number-WithError-1.10.0.ebuild
new file mode 100644
index 000000000000..f33ff808f67d
--- /dev/null
+++ b/dev-perl/Number-WithError/Number-WithError-1.10.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SMUELLER
+DIST_VERSION=1.01
+inherit perl-module
+
+DESCRIPTION="Numbers with error propagation and scientific rounding"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Math-BigInt-1.400.0
+ >=dev-perl/Params-Util-0.100.0
+ >=dev-perl/prefork-1.0.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+ test? (
+ dev-perl/Test-LectroTest
+ >=virtual/perl-Test-Simple-0.470.0
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-${DIST_VERSION}-no-dot-inc.patch"
+)
+PERL_RM_FILES=(
+ "t/00podcover.t"
+ "t/00pod.t"
+)
diff --git a/dev-perl/Number-WithError/files/Number-WithError-1.01-no-dot-inc.patch b/dev-perl/Number-WithError/files/Number-WithError-1.01-no-dot-inc.patch
new file mode 100644
index 000000000000..62c40029cdcf
--- /dev/null
+++ b/dev-perl/Number-WithError/files/Number-WithError-1.01-no-dot-inc.patch
@@ -0,0 +1,24 @@
+From 8c15ff58866e38cb8ce4f7b7ad3ecac941f5863d Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Fri, 7 Sep 2018 20:23:23 +1200
+Subject: Fix Makefile.PL to work on perl 5.26+/no-dot-inc perls
+
+Perl 5.26+ have @INC without '.' unless PERL_USE_UNSAFE_INC=1
+
+Perl 5.30+ will have no hack to avoid this problem \o/
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 76b23e1..a3c10b1 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,3 +1,4 @@
++use lib '.';
+ use inc::Module::Install;
+
+ name 'Number-WithError';
+--
+2.17.1
+
diff --git a/dev-perl/Number-WithError/metadata.xml b/dev-perl/Number-WithError/metadata.xml
new file mode 100644
index 000000000000..91fdeb8c1632
--- /dev/null
+++ b/dev-perl/Number-WithError/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Number-WithError</remote-id>
+ <remote-id type="cpan-module">Number::WithError</remote-id>
+ </upstream>
+</pkgmetadata>