summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-12-24 13:54:14 +1300
committerKent Fredric <kentnl@gentoo.org>2017-12-26 21:48:01 +1300
commitef5266e09a0e483ec2b4636eb36d48fe18b841d9 (patch)
treec75bb687023309cf6aa9e9ac3dcc216879f8d1ab /dev-perl/PDF-API2
parentdev-ruby/rubygems: add 2.7.4 (diff)
downloadgentoo-ef5266e09a0e483ec2b4636eb36d48fe18b841d9.tar.gz
gentoo-ef5266e09a0e483ec2b4636eb36d48fe18b841d9.tar.bz2
gentoo-ef5266e09a0e483ec2b4636eb36d48fe18b841d9.zip
dev-perl/PDF-API2: Bump to version 2.33.0
Upstream: - Fix Bank Gothic core font - Weaken references for garbage collection improvements - Remove warning for ambiguous call to CORE::open - text_{fill_,}justified now adjust word-space instead of character space stretching. - Fix buffering for multiline embedded indirect comments. - Fix open(filename)->stringify - Fix off-by-one calculating text width - Fix synfont Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl/PDF-API2')
-rw-r--r--dev-perl/PDF-API2/Manifest1
-rw-r--r--dev-perl/PDF-API2/PDF-API2-2.33.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/PDF-API2/Manifest b/dev-perl/PDF-API2/Manifest
index f1b55f07f861..9e2edd98f22a 100644
--- a/dev-perl/PDF-API2/Manifest
+++ b/dev-perl/PDF-API2/Manifest
@@ -1,2 +1,3 @@
DIST PDF-API2-2.027.tar.gz 3500950 BLAKE2B 525839ff4a69434929483c169192d3cb891e757a4daa0c885d6e83a254e5d4d241cae5e96a5a4aa67531364b4ed7a72c706d4fd771dbaa6b1ce09fca56254a05 SHA512 39729907418b863dd97b4b5051584eac5baddc9639a1b92caa5045a5237e41d37ae267fafd37c3a89d8160f8d9b3fb3bdbc903e1cd3de9e4df158cacb8e5c1d8
DIST PDF-API2-2.031.tar.gz 3507672 BLAKE2B 3976957dc247f2ee094932dda6c20b5f887b56dfa61724fc3561394dbe995f87a8253f9a4cb8189446770daae71adac3d9fdd9ae7a8fedd24d614b8d9eecf2ed SHA512 967e6925658ba11d60c065230df78ce32d087ab1ecdd63a4c80c2f87d908db6f18d1bd8cf4021b3520a324bbedaa434f1691873f3cad0a75831e61c03323f4a6
+DIST PDF-API2-2.033.tar.gz 3533753 BLAKE2B 4a99cb7e01b69e07f8d3f3968f8a1d8e388707dc35e034cb862a3d587d91b5701acf724842b55c6bc010754103ceee3f90e8ce625ff1d7ee850f0bb63720ff03 SHA512 8579114492c8b8fcd8ad7b837e8dea1f7157803b2519883308696f78ce1597688bf5f3b06d13971b5a8302eb03636557de3a7092b8386a6e177748c4b3748ea5
diff --git a/dev-perl/PDF-API2/PDF-API2-2.33.0.ebuild b/dev-perl/PDF-API2/PDF-API2-2.33.0.ebuild
new file mode 100644
index 000000000000..a1132a91efc7
--- /dev/null
+++ b/dev-perl/PDF-API2/PDF-API2-2.33.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SSIMMS
+DIST_VERSION=2.033
+DIST_EXAMPLES=( "contrib/*" )
+inherit perl-module
+
+DESCRIPTION="Facilitates the creation and modification of PDF files"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="examples test"
+
+RDEPEND="
+ >=virtual/perl-IO-Compress-1.0.0
+ dev-perl/Font-TTF"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Exception
+ dev-perl/Test-Memory-Cycle
+ )
+"
+src_test() {
+ perl_rm_files t/author-*.t
+ perl-module_src_test
+}