summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/POE/POE-1.356-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/POE/POE-1.356-r1.ebuild')
-rw-r--r--dev-perl/POE/POE-1.356-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-perl/POE/POE-1.356-r1.ebuild b/dev-perl/POE/POE-1.356-r1.ebuild
new file mode 100644
index 000000000000..deb52c22ce5f
--- /dev/null
+++ b/dev-perl/POE/POE-1.356-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+POE_TEST_LOOPS_VERSION=1.351.0
+MODULE_AUTHOR=RCAPUTO
+MODULE_VERSION=1.356
+inherit perl-module
+
+DESCRIPTION="A framework for creating multitasking programs in Perl"
+
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="ipv6 libwww ncurses tk test"
+
+RDEPEND="
+ >=dev-perl/Event-1.09
+ >=virtual/perl-File-Spec-0.87
+ >=virtual/perl-IO-1.23.01
+ >=virtual/perl-IO-Compress-1.33
+ >=virtual/perl-Storable-2.12
+ >=dev-perl/IO-Tty-1.08
+ dev-perl/Filter
+ dev-perl/FreezeThaw
+ dev-perl/yaml
+ >=dev-perl/TermReadKey-2.21
+ >=virtual/perl-Time-HiRes-1.59
+ ipv6? (
+ >=dev-perl/Socket6-0.14
+ )
+ tk? (
+ >=dev-perl/perl-tk-800.027
+ )
+ libwww? (
+ >=dev-perl/libwww-perl-5.79
+ >=dev-perl/URI-1.30
+ )
+ ncurses? (
+ >=dev-perl/Curses-1.08
+ )
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-perl/POE-Test-Loops-${POE_TEST_LOOPS_VERSION}
+ >=virtual/perl-Test-Harness-2.26
+ >=virtual/perl-Test-Simple-0.54
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ dev-perl/IO-Pipely
+ )
+"
+
+SRC_TEST=do
+
+src_test() {
+ # Disable network tests
+ rm -f "${S}"/run_network_tests
+ perl-module_src_test
+}