summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-04-07 00:47:46 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-08 01:07:41 +0200
commit21928a595f1e4a3faea68c6ba97d183a77ec1579 (patch)
treea7192eec09051794cc0430faa16bd5fd896d8ac8 /dev-perl/PPIx-Regexp/PPIx-Regexp-0.48.0.ebuild
parentdev-perl/PostScript-Simple: Bump to version 0.90.0 (diff)
downloadgentoo-21928a595f1e4a3faea68c6ba97d183a77ec1579.tar.gz
gentoo-21928a595f1e4a3faea68c6ba97d183a77ec1579.tar.bz2
gentoo-21928a595f1e4a3faea68c6ba97d183a77ec1579.zip
dev-perl/PPIx-Regexp: Bump to version 0.48.0
- EAPI6 - Added USE="examples" Upstream: - MultiCharacter modifiers supported - Invalid \g and \k backrefs now considered errors - error() method added to elements - added modifier_asserted() to check for modifier influence - non-ascii whitespace under /x supported for perl >=5.21.1 - replacements in s///ee now considered code - arity of modifier use now available on Tokens - \b{unknownthing} is now an error - \b{gcb} \b{wb} \b{sb} \b{lb} now supported - Nested subscripts in interpolation detected - Interpret /n capture-group semantics like perl>=5.21.8 does - PPIx::Regexp::Dumper now reports structures missing delimiters - Parsing all-space strings a parse error - Treat \U as a meta-character in \Q\E - Better parising of ']' and whitespace in []'s - Better \Q,\U,\L,\F,\E nesting. - Only recognise \k in replacements, not \k{} or \g{} - Postfix-deref parse support added - explain(), main_structure() and in_regex_set() methods added. - prior() deprecated - Now accepts strings to parse() - \N{} is a no-op - added strict mode. Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-perl/PPIx-Regexp/PPIx-Regexp-0.48.0.ebuild')
-rw-r--r--dev-perl/PPIx-Regexp/PPIx-Regexp-0.48.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/PPIx-Regexp/PPIx-Regexp-0.48.0.ebuild b/dev-perl/PPIx-Regexp/PPIx-Regexp-0.48.0.ebuild
new file mode 100644
index 000000000000..a78b9476e24f
--- /dev/null
+++ b/dev-perl/PPIx-Regexp/PPIx-Regexp-0.48.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=WYANT
+DIST_VERSION=0.048
+inherit perl-module
+
+DESCRIPTION="Represent a regular expression of some sort"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test examples"
+
+RDEPEND="
+ dev-perl/List-MoreUtils
+ >=dev-perl/PPI-1.117.0
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? ( virtual/perl-Test-Simple )
+"
+
+src_install() {
+ perl-module_src_install
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ docinto examples
+ dodoc -r eg/*
+ fi
+}