summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Params-Validate
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Params-Validate')
-rw-r--r--dev-perl/Params-Validate/Manifest2
-rw-r--r--dev-perl/Params-Validate/Params-Validate-1.70.0-r1.ebuild29
-rw-r--r--dev-perl/Params-Validate/Params-Validate-1.80.0.ebuild32
-rw-r--r--dev-perl/Params-Validate/metadata.xml13
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-perl/Params-Validate/Manifest b/dev-perl/Params-Validate/Manifest
new file mode 100644
index 000000000000..4eab0d7a3c54
--- /dev/null
+++ b/dev-perl/Params-Validate/Manifest
@@ -0,0 +1,2 @@
+DIST Params-Validate-1.07.tar.gz 100822 SHA256 c1df34746723480336b5357a5007afa219ed2c8330d462c6c854f6ac3a17bf96 SHA512 fc49cdba84a1d9cc3d526fd86328bf724adbfee7c161c4bcc2dac84b6a9a4369f50f216be23606e3bef46ba58aa476be38f93075a068941245ca4ab6393d75d6 WHIRLPOOL 64b488969d36cb81ed10fbff7e7a1d4d4af71ce56a347a05f74b598cf854bf316bda5ead1ce14c31d3a0cfa1b87a0517ba796c593632c466bef4dbe55d49f34c
+DIST Params-Validate-1.08.tar.gz 103728 SHA256 d04096fcf402e6b9637d2b74d37f8007ba63dab4b289ded0b4d2f455fe828118 SHA512 30bbd698d9c559a47194782ae4da740c4418775d6a21fc98cf755e3c0d1615a58fb79f43f7935a22cb2eb6e2f744440f296bca17485add480b6c3191493c5dc0 WHIRLPOOL c76c9ad82fe4b5a1cf55505a8b45040aee2e86875537ecece4686041e1484b6893dceabbbe3bfc5b6c16fab0714f1a8d4b02307c5c3f4e2ca664c370c7187a0a
diff --git a/dev-perl/Params-Validate/Params-Validate-1.70.0-r1.ebuild b/dev-perl/Params-Validate/Params-Validate-1.70.0-r1.ebuild
new file mode 100644
index 000000000000..efb964168b36
--- /dev/null
+++ b/dev-perl/Params-Validate/Params-Validate-1.70.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=1.07
+inherit perl-module
+
+DESCRIPTION="A module to provide a flexible system for validation method/function call parameters"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Attribute-Handlers
+ dev-perl/Module-Implementation
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.35
+ test? (
+ dev-perl/Test-Fatal
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Params-Validate/Params-Validate-1.80.0.ebuild b/dev-perl/Params-Validate/Params-Validate-1.80.0.ebuild
new file mode 100644
index 000000000000..8819893dff98
--- /dev/null
+++ b/dev-perl/Params-Validate/Params-Validate-1.80.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=1.08
+inherit perl-module
+
+DESCRIPTION="A module to provide a flexible system for validation method/function call parameters"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Attribute-Handlers
+ dev-perl/Module-Implementation
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.35
+ test? (
+ dev-perl/Test-Fatal
+ dev-perl/Readonly
+ dev-perl/Readonly-XS
+ dev-perl/Test-Taint
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Params-Validate/metadata.xml b/dev-perl/Params-Validate/metadata.xml
new file mode 100644
index 000000000000..1325b9add2da
--- /dev/null
+++ b/dev-perl/Params-Validate/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Params-Validate</remote-id>
+ <remote-id type="cpan-module">Attribute::Params::Validate</remote-id>
+ <remote-id type="cpan-module">Params::Validate</remote-id>
+ <remote-id type="cpan-module">Params::Validate::Constants</remote-id>
+ <remote-id type="cpan-module">Params::Validate::PP</remote-id>
+ <remote-id type="cpan-module">Params::Validate::XS</remote-id>
+ </upstream>
+</pkgmetadata>