summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-24 23:42:02 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-24 23:42:02 +0200
commit6835bd36efa45463bd09140611f8a6b8c814bf70 (patch)
treef967cd03326f9bde26d7871762421a0ca040af87 /dev-perl/Params-ValidationCompiler
parentdev-perl/Params-Validate: Version bump 1.30 (diff)
downloadgentoo-6835bd36efa45463bd09140611f8a6b8c814bf70.tar.gz
gentoo-6835bd36efa45463bd09140611f8a6b8c814bf70.tar.bz2
gentoo-6835bd36efa45463bd09140611f8a6b8c814bf70.zip
dev-perl/Params-ValidationCompiler: Version bump 0.30
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Params-ValidationCompiler')
-rw-r--r--dev-perl/Params-ValidationCompiler/Manifest1
-rw-r--r--dev-perl/Params-ValidationCompiler/Params-ValidationCompiler-0.300.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Params-ValidationCompiler/Manifest b/dev-perl/Params-ValidationCompiler/Manifest
index 228b4b9b4e85..4bdc73cffb09 100644
--- a/dev-perl/Params-ValidationCompiler/Manifest
+++ b/dev-perl/Params-ValidationCompiler/Manifest
@@ -1 +1,2 @@
DIST Params-ValidationCompiler-0.26.tar.gz 44588 BLAKE2B 8dc61a15e7a559ead00f6e9a4c05c0eb17f14cebfc29ad69db2c0c4814eab9ee84312cfa98c4683b9b7c6487af5c47afa47cf33600a1209195cb8e7b016dc657 SHA512 f393b1cf063ea4e504ddbc863b4f478924b071810431b7817bf6faeb1fe632cbd493bc2e96033dccc99c4ecb5fdba072044f90387c92f262b54cf8f0b0386c0b
+DIST Params-ValidationCompiler-0.30.tar.gz 49796 BLAKE2B d6a50a1b8c457a961677586e364f43ab039b8df26c8349befa37e77c565dd4b24b5d88e0c54697c66d8ff69776b6bf69ab810a6f3ab78a9565163c5371bcf80d SHA512 5911f9317f0b72e17c72435420a3b6b9f36780ab70715510c46e847970094e730169b9b3085f29cb23ee0aca2e78f7f9edd0d093859a1062869f35c90172bf05
diff --git a/dev-perl/Params-ValidationCompiler/Params-ValidationCompiler-0.300.0.ebuild b/dev-perl/Params-ValidationCompiler/Params-ValidationCompiler-0.300.0.ebuild
new file mode 100644
index 000000000000..27dbdbea7cf1
--- /dev/null
+++ b/dev-perl/Params-ValidationCompiler/Params-ValidationCompiler-0.300.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=0.30
+DIST_EXAMPLES=("eg/*")
+inherit perl-module
+
+DESCRIPTION="Build an optimized subroutine parameter validator once, use it forever"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+LICENSE="Artistic-2"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Eval-Closure
+ dev-perl/Exception-Class
+ virtual/perl-Exporter
+ >=virtual/perl-Scalar-List-Utils-1.400.0
+"
+
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ >=dev-perl/Specio-0.140.0
+ >=virtual/perl-Test-Simple-1.302.15
+ dev-perl/Test-Without-Module
+ >=dev-perl/Test2-Suite-0.0.72
+ dev-perl/Test2-Plugin-NoWarnings
+ )
+"