summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-24 23:57:17 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-24 23:57:17 +0200
commit3401303a5395c2a063391012ac53179bebd9120f (patch)
tree386ff2a879f9507887d3429036298218989d3297 /dev-perl/Path-Class/Path-Class-0.370.0-r1.ebuild
parentdev-perl/PatchReader: EAPI=8 bump (diff)
downloadgentoo-3401303a5395c2a063391012ac53179bebd9120f.tar.gz
gentoo-3401303a5395c2a063391012ac53179bebd9120f.tar.bz2
gentoo-3401303a5395c2a063391012ac53179bebd9120f.zip
dev-perl/Path-Class: EAPI=8 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Path-Class/Path-Class-0.370.0-r1.ebuild')
-rw-r--r--dev-perl/Path-Class/Path-Class-0.370.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Path-Class/Path-Class-0.370.0-r1.ebuild b/dev-perl/Path-Class/Path-Class-0.370.0-r1.ebuild
new file mode 100644
index 000000000000..45e0cae0f11b
--- /dev/null
+++ b/dev-perl/Path-Class/Path-Class-0.370.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=KWILLIAMS
+DIST_VERSION=0.37
+inherit perl-module
+
+DESCRIPTION="Cross-platform path specification manipulation"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-File-Path
+ >=virtual/perl-File-Spec-3.260.0
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ virtual/perl-Perl-OSType
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-parent
+"
+
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.360.100
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ virtual/perl-Test
+ virtual/perl-Test-Simple
+ )
+"
+
+PERL_RM_FILES=( "t/author-critic.t" )