summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-05-30 13:15:02 +1200
committerKent Fredric <kentnl@gentoo.org>2017-05-30 13:15:02 +1200
commit24017d9293353cd350d871ac5b3a67e22e01a20f (patch)
treeb7373f7dc473a8e6e92b75d96d1205a9bb1a36e2 /dev-perl/Perl-Tidy/Perl-Tidy-20170521.0.0.ebuild
parentdev-perl/Net-HTTP: Bump to version 6.160.0 (diff)
downloadgentoo-24017d9293353cd350d871ac5b3a67e22e01a20f.tar.gz
gentoo-24017d9293353cd350d871ac5b3a67e22e01a20f.tar.bz2
gentoo-24017d9293353cd350d871ac5b3a67e22e01a20f.zip
dev-perl/Perl-Tidy: Bump to version 20170521.0.0
- Use DIST_EXAMPLES logic Upstream: - Fix symlink attack from failure to check perltidy.ERR deletion - Don't mis-parse certain anonymous hash references - Don't parse => after __END__ or __DATA__ as quotes - Fix parsing of perltidyrc - Add support for <<>> operator. - Fix --enc=utf8 + --backup-and-modify-in-place - Fix minor formatting issue with one-line blocks with subs with sigs - Fix utf8 error when output is STDOUT - Improve spacing of try/catch/finally blocks - Fix incorrect parsing of anon-subs with sigs and prototypes as broken ternaries - Add new open/closing block blank line controls Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Perl-Tidy/Perl-Tidy-20170521.0.0.ebuild')
-rw-r--r--dev-perl/Perl-Tidy/Perl-Tidy-20170521.0.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Perl-Tidy/Perl-Tidy-20170521.0.0.ebuild b/dev-perl/Perl-Tidy/Perl-Tidy-20170521.0.0.ebuild
new file mode 100644
index 000000000000..c854b45911e3
--- /dev/null
+++ b/dev-perl/Perl-Tidy/Perl-Tidy-20170521.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SHANCOCK
+DIST_VERSION=20170521
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module
+
+DESCRIPTION="Perl script indenter and beautifier"
+HOMEPAGE="http://perltidy.sourceforge.net/ ${HOMEPAGE}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+src_install() {
+ perl-module_src_install
+
+ # Compressing pod is bad because perldoc can't decompress
+ # bzip2 automatically, and `less` can't render perldoc
+ docompress -x /usr/share/doc/${PF}/stylekey.pod
+ docompress -x /usr/share/doc/${PF}/tutorial
+
+ docinto ''
+ dodoc docs/stylekey.pod
+
+ docinto tutorial
+ dodoc docs/tutorial.pod docs/testfile.pl
+}