summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/SOAP-Lite
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/SOAP-Lite')
-rw-r--r--dev-perl/SOAP-Lite/Manifest2
-rw-r--r--dev-perl/SOAP-Lite/SOAP-Lite-1.040.0-r1.ebuild46
-rw-r--r--dev-perl/SOAP-Lite/SOAP-Lite-1.140.0.ebuild51
-rw-r--r--dev-perl/SOAP-Lite/metadata.xml96
4 files changed, 195 insertions, 0 deletions
diff --git a/dev-perl/SOAP-Lite/Manifest b/dev-perl/SOAP-Lite/Manifest
new file mode 100644
index 000000000000..55a747e81be7
--- /dev/null
+++ b/dev-perl/SOAP-Lite/Manifest
@@ -0,0 +1,2 @@
+DIST SOAP-Lite-1.04.tar.gz 222598 SHA256 30dd8240cc79e58d3fa4d314f9bde174ca90a481ab5904f58c84bc8812bc7887 SHA512 3f9ac332ff1b914b9de155c9662f46838aaec8c0a45b29f8eac383286eea63bebfc6a4a5124dec14292176c45c6cc35ba06657a03cc0d3b1331fe9a9d6f17eaa WHIRLPOOL 5d1a9e595d83eaf82a2be4cb2a0afaf8c1fbe744433ab1e70e40ef8e522cb54e11ce0917ea1858a55d353da86290f95137690e2021d78f842c9ff4537f3df3c0
+DIST SOAP-Lite-1.14.tar.gz 276774 SHA256 a201bed80db9b76a4ada9768281489c070fb8a25f4481d1296c92a5111ce1756 SHA512 6ad26f69aeb7ebf1b05c64e30e42918f970a0eaaf6c764baa4cc21a931e13921ba3d4796175324bf3e4e5c11b05f59d84bb17a49d87a1579024b242e251255ab WHIRLPOOL 260301ed3a9468e4a255842963dfc6094e1773575f7ddb80feeaad6b39325df5a361d0e329a40b8a5ed31af8f14ee4bb2930bfc0bf719eac3b1dc9f2bbb18a16
diff --git a/dev-perl/SOAP-Lite/SOAP-Lite-1.040.0-r1.ebuild b/dev-perl/SOAP-Lite/SOAP-Lite-1.040.0-r1.ebuild
new file mode 100644
index 000000000000..802289dfa423
--- /dev/null
+++ b/dev-perl/SOAP-Lite/SOAP-Lite-1.040.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=PHRED
+MODULE_VERSION=1.04
+inherit perl-module eutils
+
+DESCRIPTION="Simple and lightweight interface to the SOAP protocol (sic) both on client and server side"
+
+IUSE="ssl xmpp"
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+
+myconf="${myconf} --noprompt"
+
+# TESTS ARE DISABLED ON PURPOSE
+# This module attempts to access an external website for validation
+# of the MIME::Parser - not only is that bad practice in general,
+# but in this particular case the external site isn't even valid anymore# -mpc
+# 24/10/04
+SRC_TEST="do"
+
+DEPEND="
+ dev-perl/Class-Inspector
+ dev-perl/XML-Parser
+ dev-perl/libwww-perl
+ virtual/perl-libnet
+ dev-perl/MIME-Lite
+ virtual/perl-MIME-Base64
+ ssl? ( dev-perl/Crypt-SSLeay )
+ xmpp? ( dev-perl/Net-Jabber )
+ ssl? ( dev-perl/IO-Socket-SSL )
+ virtual/perl-IO-Compress
+ >=dev-perl/MIME-tools-5.413
+ virtual/perl-version
+"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ has_version '>=www-apache/mod_perl-2' && export MOD_PERL_API_VERSION=2
+ perl-module_src_test
+}
diff --git a/dev-perl/SOAP-Lite/SOAP-Lite-1.140.0.ebuild b/dev-perl/SOAP-Lite/SOAP-Lite-1.140.0.ebuild
new file mode 100644
index 000000000000..5f764ad55b3d
--- /dev/null
+++ b/dev-perl/SOAP-Lite/SOAP-Lite-1.140.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=PHRED
+MODULE_VERSION=1.14
+inherit perl-module eutils
+
+DESCRIPTION="Simple and lightweight interface to the SOAP protocol (sic) both on client and server side"
+
+IUSE="ssl test xmpp"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+myconf="${myconf} --noprompt"
+
+RDEPEND="
+ dev-perl/Class-Inspector
+ >=dev-perl/IO-SessionData-1.30.0
+ dev-perl/libwww-perl
+ virtual/perl-MIME-Base64
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Task-Weaken
+ dev-perl/URI
+ dev-perl/XML-Parser
+ dev-perl/MIME-tools
+ ssl? (
+ dev-perl/IO-Socket-SSL
+ dev-perl/LWP-Protocol-https
+ dev-perl/Crypt-SSLeay
+ )
+ xmpp? ( dev-perl/Net-Jabber )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-IO
+ virtual/perl-Test-Simple
+ dev-perl/Test-Warn
+ dev-perl/XML-Parser-Lite
+ )
+"
+
+SRC_TEST="do"
+
+src_test() {
+ has_version '>=www-apache/mod_perl-2' && export MOD_PERL_API_VERSION=2
+ perl-module_src_test
+}
diff --git a/dev-perl/SOAP-Lite/metadata.xml b/dev-perl/SOAP-Lite/metadata.xml
new file mode 100644
index 000000000000..816f3960ec09
--- /dev/null
+++ b/dev-perl/SOAP-Lite/metadata.xml
@@ -0,0 +1,96 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">SOAP-Lite</remote-id>
+ <remote-id type="cpan-module">Apache::SOAP</remote-id>
+ <remote-id type="cpan-module">Apache::XMLRPC::Lite</remote-id>
+ <remote-id type="cpan-module">LWP::Protocol</remote-id>
+ <remote-id type="cpan-module">My::PingPong</remote-id>
+ <remote-id type="cpan-module">SOAP</remote-id>
+ <remote-id type="cpan-module">SOAP::Client</remote-id>
+ <remote-id type="cpan-module">SOAP::Cloneable</remote-id>
+ <remote-id type="cpan-module">SOAP::Constants</remote-id>
+ <remote-id type="cpan-module">SOAP::Custom::XML::Data</remote-id>
+ <remote-id type="cpan-module">SOAP::Custom::XML::Deserializer</remote-id>
+ <remote-id type="cpan-module">SOAP::Data</remote-id>
+ <remote-id type="cpan-module">SOAP::Deserializer</remote-id>
+ <remote-id type="cpan-module">SOAP::Fault</remote-id>
+ <remote-id type="cpan-module">SOAP::Header</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::COM</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::Deserializer::XMLSchema1999</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::Deserializer::XMLSchema2001</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::Deserializer::XMLSchemaSOAP1_1</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::Deserializer::XMLSchemaSOAP1_2</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::Packager</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::Packager::DIME</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::Packager::MIME</remote-id>
+ <remote-id type="cpan-module">SOAP::Lite::Utils</remote-id>
+ <remote-id type="cpan-module">SOAP::Packager</remote-id>
+ <remote-id type="cpan-module">SOAP::Packager::DIME</remote-id>
+ <remote-id type="cpan-module">SOAP::Packager::MIME</remote-id>
+ <remote-id type="cpan-module">SOAP::Parser</remote-id>
+ <remote-id type="cpan-module">SOAP::SOM</remote-id>
+ <remote-id type="cpan-module">SOAP::Schema</remote-id>
+ <remote-id type="cpan-module">SOAP::Schema::Deserializer</remote-id>
+ <remote-id type="cpan-module">SOAP::Schema::WSDL</remote-id>
+ <remote-id type="cpan-module">SOAP::Serializer</remote-id>
+ <remote-id type="cpan-module">SOAP::Server</remote-id>
+ <remote-id type="cpan-module">SOAP::Server::Object</remote-id>
+ <remote-id type="cpan-module">SOAP::Server::Parameters</remote-id>
+ <remote-id type="cpan-module">SOAP::Test</remote-id>
+ <remote-id type="cpan-module">SOAP::Test::Server</remote-id>
+ <remote-id type="cpan-module">SOAP::Trace</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::HTTP</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::HTTP::Apache</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::HTTP::CGI</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::HTTP::Client</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::HTTP::Daemon</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::HTTP::FCGI</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::HTTP::Server</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::IO</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::IO::Server</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::LOCAL</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::LOCAL::Client</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::LOOPBACK</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::LOOPBACK::Client</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::MAILTO</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::MAILTO::Client</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::POP3</remote-id>
+ <remote-id type="cpan-module">SOAP::Transport::POP3::Server</remote-id>
+ <remote-id type="cpan-module">SOAP::Utils</remote-id>
+ <remote-id type="cpan-module">SOAP::XMLSchema1999::Serializer</remote-id>
+ <remote-id type="cpan-module">SOAP::XMLSchema2001::Serializer</remote-id>
+ <remote-id type="cpan-module">SOAP::XMLSchema::Serializer</remote-id>
+ <remote-id type="cpan-module">SOAP::XMLSchemaApacheSOAP::Deserializer</remote-id>
+ <remote-id type="cpan-module">UDDI::Constants</remote-id>
+ <remote-id type="cpan-module">UDDI::Data</remote-id>
+ <remote-id type="cpan-module">UDDI::Deserializer</remote-id>
+ <remote-id type="cpan-module">UDDI::Lite</remote-id>
+ <remote-id type="cpan-module">UDDI::SOM</remote-id>
+ <remote-id type="cpan-module">UDDI::Serializer</remote-id>
+ <remote-id type="cpan-module">XML::Parser::Lite</remote-id>
+ <remote-id type="cpan-module">XMLRPC</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Constants</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Data</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Deserializer</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Lite</remote-id>
+ <remote-id type="cpan-module">XMLRPC::SOM</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Serializer</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Server</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Server::Parameters</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Test</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Test::Server</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Transport::HTTP</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Transport::HTTP::Apache</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Transport::HTTP::CGI</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Transport::HTTP::Daemon</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Transport::POP3</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Transport::POP3::Server</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Transport::TCP</remote-id>
+ <remote-id type="cpan-module">XMLRPC::Transport::TCP::Server</remote-id>
+ </upstream>
+</pkgmetadata>