summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-10-06 07:08:04 -0400
committerAnthony G. Basile <blueness@gentoo.org>2017-10-06 07:08:04 -0400
commit69071a14be09ff3d4da2e8ca27caca6af38eedd2 (patch)
tree222f1ee4e6a3a1e5830b38238b0fe7c564fc1993 /dev-perl/Search-Xapian/Search-Xapian-1.2.25.0.ebuild
parentapp-text/xapian-omega: version bump 1.2 branch to 1.2.25 (diff)
downloadgentoo-69071a14be09ff3d4da2e8ca27caca6af38eedd2.tar.gz
gentoo-69071a14be09ff3d4da2e8ca27caca6af38eedd2.tar.bz2
gentoo-69071a14be09ff3d4da2e8ca27caca6af38eedd2.zip
dev-perl/Search-Xapian: version bump to 1.2.25.0
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Search-Xapian/Search-Xapian-1.2.25.0.ebuild')
-rw-r--r--dev-perl/Search-Xapian/Search-Xapian-1.2.25.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Search-Xapian/Search-Xapian-1.2.25.0.ebuild b/dev-perl/Search-Xapian/Search-Xapian-1.2.25.0.ebuild
new file mode 100644
index 000000000000..e5fe760739e3
--- /dev/null
+++ b/dev-perl/Search-Xapian/Search-Xapian-1.2.25.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=OLLY
+inherit perl-module toolchain-funcs versionator
+
+VERSION=$(get_version_component_range 1-3)
+
+SRC_URI+=" http://oligarchy.co.uk/xapian/${VERSION}/${P}.tar.gz"
+DESCRIPTION="Perl XS frontend to the Xapian C++ search library"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples test"
+
+RDEPEND="dev-libs/xapian:0/1.2.22
+ !dev-libs/xapian-bindings[perl]"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( dev-perl/Devel-Leak )
+"
+
+DIST_TEST=do
+# parallel fails sometimes...
+
+myconf="CXX=$(tc-getCXX) CXXFLAGS=${CXXFLAGS}"
+
+src_install() {
+ perl-module_src_install
+
+ use examples && {
+ docinto examples
+ dodoc "${S}"/examples/*
+ }
+}