summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-04-11 01:35:41 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-12 00:54:10 +0200
commit3eccb21e08b496a3dccffbb7c35c257c240ce3d0 (patch)
tree70975dad086b9a5a595ff599bc755d5845971947 /dev-perl/Statistics-Descriptive/Statistics-Descriptive-3.61.200.ebuild
parentdev-perl/Starlet: Bump to version 0.29.0 (diff)
downloadgentoo-3eccb21e08b496a3dccffbb7c35c257c240ce3d0.tar.gz
gentoo-3eccb21e08b496a3dccffbb7c35c257c240ce3d0.tar.bz2
gentoo-3eccb21e08b496a3dccffbb7c35c257c240ce3d0.zip
dev-perl/Statistics-Descriptive: Bump to version 3.61.200
- EAPI6 - Add USE="examples" - Pruned useless tests Upstream: - add median_absolute_derivation method - skewness calculations sped up - Many Packaging and documentation fixes. Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-perl/Statistics-Descriptive/Statistics-Descriptive-3.61.200.ebuild')
-rw-r--r--dev-perl/Statistics-Descriptive/Statistics-Descriptive-3.61.200.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Statistics-Descriptive/Statistics-Descriptive-3.61.200.ebuild b/dev-perl/Statistics-Descriptive/Statistics-Descriptive-3.61.200.ebuild
new file mode 100644
index 000000000000..17709c9dbf29
--- /dev/null
+++ b/dev-perl/Statistics-Descriptive/Statistics-Descriptive-3.61.200.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=SHLOMIF
+DIST_VERSION=3.0612
+inherit perl-module
+
+DESCRIPTION="Module of basic descriptive statistical functions"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test examples"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/List-MoreUtils
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.360.0
+ test? ( virtual/perl-Test-Simple )
+"
+mydoc="UserSurvey.txt"
+
+src_test() {
+ perl_rm_files "t/pod-coverage.t" "t/pod.t" "t/cpan-changes.t" "t/style-trailing-space.t"
+ perl-module_src_test
+}
+src_install() {
+ perl-module_src_install
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples/
+ dodoc -r examples
+ fi
+}