summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Sys-Hostname-Long
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Sys-Hostname-Long')
-rw-r--r--dev-perl/Sys-Hostname-Long/Manifest2
-rw-r--r--dev-perl/Sys-Hostname-Long/Sys-Hostname-Long-1.400.0-r1.ebuild22
-rw-r--r--dev-perl/Sys-Hostname-Long/Sys-Hostname-Long-1.500.0.ebuild22
-rw-r--r--dev-perl/Sys-Hostname-Long/metadata.xml9
4 files changed, 55 insertions, 0 deletions
diff --git a/dev-perl/Sys-Hostname-Long/Manifest b/dev-perl/Sys-Hostname-Long/Manifest
new file mode 100644
index 000000000000..fce40f61f01b
--- /dev/null
+++ b/dev-perl/Sys-Hostname-Long/Manifest
@@ -0,0 +1,2 @@
+DIST Sys-Hostname-Long-1.4.tar.gz 4991 SHA256 9db6c8cd3ca0ba8dbf19969ed0a936cecb7f555c1cc8077b08cf8bf78b10c143 SHA512 a9a4ac20eaa7c959899d4f545a9613fd32ae813cc2bf071c44e94b03d0cbc69e5d962fdd2563aef657ab4250b49a5b44cd07d117a97f6dcda580a66fb4644287 WHIRLPOOL 571be9734981324946e1f27d60b6120a469ecb1d560360b555da22b68b56a0e5de84504ebc58f57ae08dfd5c3d917e559d927f7c14671c9c97b192838649d2dc
+DIST Sys-Hostname-Long-1.5.tar.gz 5474 SHA256 e9186df3706a877efd6149f2c711d6cf87dd6cf72f6ab935ba8121b225b265cb SHA512 e34a5f17e65eb9c8d3aa213a6d930be4d0b6981dae3bf600e782b0e9863e6584061285a894f9f54daff7520bcadbb3e8cd6b1f9f973ad1c1b72c79e9f588133b WHIRLPOOL 3ecb794b3500c65287abe443948b91a3ed18f1a4a977f7650d398f0f639e38faf499a5ebd4bb6a93cf688b885069d4cc2b88d25a67cd08478c6ba4b8adc0c030
diff --git a/dev-perl/Sys-Hostname-Long/Sys-Hostname-Long-1.400.0-r1.ebuild b/dev-perl/Sys-Hostname-Long/Sys-Hostname-Long-1.400.0-r1.ebuild
new file mode 100644
index 000000000000..2138610748cb
--- /dev/null
+++ b/dev-perl/Sys-Hostname-Long/Sys-Hostname-Long-1.400.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SCOTT
+MODULE_VERSION=1.4
+inherit perl-module
+
+DESCRIPTION="Try every conceivable way to get full hostname"
+
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+src_install() {
+ perl-module_src_install
+ rm "${ED}${VENDOR_LIB}"/Sys/Hostname/testall.pl || die
+ dodoc testall.pl
+ docompress -x /usr/share/doc/${PF}/testall.pl
+}
diff --git a/dev-perl/Sys-Hostname-Long/Sys-Hostname-Long-1.500.0.ebuild b/dev-perl/Sys-Hostname-Long/Sys-Hostname-Long-1.500.0.ebuild
new file mode 100644
index 000000000000..350ce571361f
--- /dev/null
+++ b/dev-perl/Sys-Hostname-Long/Sys-Hostname-Long-1.500.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SCOTT
+MODULE_VERSION=1.5
+inherit perl-module
+
+DESCRIPTION="Try every conceivable way to get full hostname"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+src_install() {
+ perl-module_src_install
+ rm "${ED}${VENDOR_LIB}"/Sys/Hostname/testall.pl || die
+ dodoc testall.pl
+ docompress -x /usr/share/doc/${PF}/testall.pl
+}
diff --git a/dev-perl/Sys-Hostname-Long/metadata.xml b/dev-perl/Sys-Hostname-Long/metadata.xml
new file mode 100644
index 000000000000..fd63fd94519e
--- /dev/null
+++ b/dev-perl/Sys-Hostname-Long/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Sys-Hostname-Long</remote-id>
+ <remote-id type="cpan-module">Sys::Hostname::Long</remote-id>
+ </upstream>
+</pkgmetadata>