summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-04-13 21:49:11 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-15 21:55:31 +0200
commit543c5a0a274bf8354d970d11d559f9db6cae566e (patch)
treeb9ecea96d91c7c427da73eab9fc26b8a07937e52 /dev-perl/Test-Command
parentdev-perl/Term-Shell: Bump to version 0.90.0 (diff)
downloadgentoo-543c5a0a274bf8354d970d11d559f9db6cae566e.tar.gz
gentoo-543c5a0a274bf8354d970d11d559f9db6cae566e.tar.bz2
gentoo-543c5a0a274bf8354d970d11d559f9db6cae566e.zip
dev-perl/Test-Command: Bump to version 0.110.0
- EAPI6 - Remove unwanted tests and their dependencies Upstream: - Add extra functions: exit_value, signal_value, stdout_value stdout_file, stderr_value, stderr_file Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/Test-Command')
-rw-r--r--dev-perl/Test-Command/Manifest1
-rw-r--r--dev-perl/Test-Command/Test-Command-0.110.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Test-Command/Manifest b/dev-perl/Test-Command/Manifest
index c94b6a2db763..8745c46e2055 100644
--- a/dev-perl/Test-Command/Manifest
+++ b/dev-perl/Test-Command/Manifest
@@ -1 +1,2 @@
DIST Test-Command-0.08.tar.gz 9967 SHA256 5c46f5eab3f2c6bbfde4b3ceb01fb78eb7468f381b913355ca84c61a9cf76788 SHA512 b163cf13fb0c12b9aa5fb505143e5fa5e65e2c7be4bfa9e7801a2fb2c735f148fd692e8e7020acbf63cae6ef62cf10f2ec7c5a536a06afd4ad7184c2b5339745 WHIRLPOOL 0abe0afc2cd31d58fa99506d86eadca1c60223b9704390bb5e06980f044790805ff43c7a368ccef6b195652e2dcd56500b856c114baf1ea7a4856cc1d15b22a5
+DIST Test-Command-0.11.tar.gz 10811 SHA256 28a3fc6fea73a19f563f11bd0f28186756d4c74207be6deacaad26d2081b9533 SHA512 79a8f41132b965ad4f6e8b4d97f8fb6181a1e394bcf8825abda2c8ee12dd5f6ef8d7c69df84d306c3841bb516213742c4a0a43c2f3d6b39ce6e163d6d77f45f8 WHIRLPOOL 326197df5cdc41d60a05c1306025d4ba8201fd19ac804a3f920feed4e58f9a4a2e05be5058f8c4cfd2094422c8b8b31f44f9fc30a0795d5d50f818ffc3339b9c
diff --git a/dev-perl/Test-Command/Test-Command-0.110.0.ebuild b/dev-perl/Test-Command/Test-Command-0.110.0.ebuild
new file mode 100644
index 000000000000..f8cfe96db0f0
--- /dev/null
+++ b/dev-perl/Test-Command/Test-Command-0.110.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=DANBOO
+DIST_VERSION=0.11
+inherit perl-module
+
+DESCRIPTION="Test routines for external commands"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=virtual/perl-Test-Simple-0.620.0
+"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+"
+
+src_test() {
+ perl_rm_files t/pod-coverage.t t/pod.t
+ perl-module_src_test
+}