summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-09-12 08:34:05 +1200
committerKent Fredric <kentnl@gentoo.org>2017-09-12 08:36:36 +1200
commitca1d40bfe9630aed8d9dd08692113d67ed107945 (patch)
tree66d7a99e7e40f4376563477d3523cb62d1d4329c /dev-perl/Test-Dependencies/Test-Dependencies-0.230.0.ebuild
parentdev-python/twisted: keyworded 17.5.0-r1 for ppc64, bug #614386 (diff)
downloadgentoo-ca1d40bfe9630aed8d9dd08692113d67ed107945.tar.gz
gentoo-ca1d40bfe9630aed8d9dd08692113d67ed107945.tar.bz2
gentoo-ca1d40bfe9630aed8d9dd08692113d67ed107945.zip
dev-perl/Test-Dependencies: Bump to version 0.230.0 and kill ::Heavy
This bump removes support for having ::Heavy work and forces the code paths to try the ::Light, or die() This is because there's little evidence anyone uses this, as its been broken since Perl 5.22, and allows us to consider removing rpm-build-perl without also removing Test::Dependencies (Test::Dependencies doesn't itself have any obvious consumers, but it did recently from Crypt-SMIME) Bug: https://bugs.gentoo.org/623096 Bug: https://bugs.gentoo.org/627080 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Test-Dependencies/Test-Dependencies-0.230.0.ebuild')
-rw-r--r--dev-perl/Test-Dependencies/Test-Dependencies-0.230.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Test-Dependencies/Test-Dependencies-0.230.0.ebuild b/dev-perl/Test-Dependencies/Test-Dependencies-0.230.0.ebuild
new file mode 100644
index 000000000000..567f8323af2b
--- /dev/null
+++ b/dev-perl/Test-Dependencies/Test-Dependencies-0.230.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=EHUELS
+DIST_VERSION=0.23
+inherit perl-module
+
+DESCRIPTION="Ensure that your dependency listing is complete"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-no-heavy.patch"
+ "${FILESDIR}/${P}-backcompat-test-more.patch"
+)
+RDEPEND="
+ virtual/perl-CPAN-Meta
+ dev-perl/File-Find-Rule-Perl
+ virtual/perl-Module-CoreList
+ dev-perl/Pod-Strip
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-CPAN-Meta-Requirements-2.120.620
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/perl-Module-Metadata
+ test? (
+ >=virtual/perl-Test-Simple-0.980.0
+ )
+"
+pkg_postinst() {
+ einfo 'Test::Dependencies::Heavy is now defunct in this release.'
+ einfo 'Read `perldoc Test::Dependencies::Heavy` for details.'
+}