summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Test-Most
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Test-Most')
-rw-r--r--dev-perl/Test-Most/Manifest2
-rw-r--r--dev-perl/Test-Most/Test-Most-0.310.0-r1.ebuild30
-rw-r--r--dev-perl/Test-Most/Test-Most-0.340.0.ebuild30
-rw-r--r--dev-perl/Test-Most/metadata.xml10
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-perl/Test-Most/Manifest b/dev-perl/Test-Most/Manifest
new file mode 100644
index 000000000000..9722d7cafb62
--- /dev/null
+++ b/dev-perl/Test-Most/Manifest
@@ -0,0 +1,2 @@
+DIST Test-Most-0.31.tar.gz 18272 SHA256 0ddc6034dc7cde3631dde41ecb558ed823fc07804bfd051b8ec9a70131862ab7 SHA512 ced22dad96c14443cd17f35d51cc22847647859e03d80f68159d35f35f34215310587320de13461d7f4724cd8da616620c56433a178c99135f6488b129765765 WHIRLPOOL 88d8977f3b98314ac87e9db7264ab88caf76d544ac6ce812b46fa88a906605004b469e62956eb5d5f84b329bf5ab50c78b95804e45d1b88b3a09073f95d0080b
+DIST Test-Most-0.34.tar.gz 15919 SHA256 c2820c8de65f5fa59f218ac2be9be98b22cc1bb1a1f371e04375aa3b6054e244 SHA512 00706bb25e6b9f806b536f75f66356413cdbcb19efd1c8b163fbd3357f61abe9e06e57c311eff216d36962ce74beb996db6cd4f0d2e5ed58fa5c0a0af32a33ef WHIRLPOOL 48c7f9b7877103c850c6bdb18eea32e2b0f0c8da80097b52eeac596d366b0033a09f187005ed8647d909fdfdf86e1f7de51c65abc7d8363bebda3ef610e02b24
diff --git a/dev-perl/Test-Most/Test-Most-0.310.0-r1.ebuild b/dev-perl/Test-Most/Test-Most-0.310.0-r1.ebuild
new file mode 100644
index 000000000000..beb4aaccdb87
--- /dev/null
+++ b/dev-perl/Test-Most/Test-Most-0.310.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=OVID
+MODULE_VERSION=0.31
+inherit perl-module
+
+DESCRIPTION="Most commonly needed test functions and features"
+
+SLOT="0"
+KEYWORDS="amd64 hppa ~ppc x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-perl/Exception-Class-1.140.0
+ >=dev-perl/Test-Warn-0.230.0
+ >=dev-perl/Test-Deep-0.106
+ >=dev-perl/Test-Differences-0.610.0
+ >=dev-perl/Test-Exception-0.310.0
+ >=virtual/perl-Test-Harness-3.210.0
+ >=virtual/perl-Test-Simple-0.88
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.400.0
+"
+
+SRC_TEST=do
diff --git a/dev-perl/Test-Most/Test-Most-0.340.0.ebuild b/dev-perl/Test-Most/Test-Most-0.340.0.ebuild
new file mode 100644
index 000000000000..8eefa355d5a1
--- /dev/null
+++ b/dev-perl/Test-Most/Test-Most-0.340.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=OVID
+MODULE_VERSION=0.34
+inherit perl-module
+
+DESCRIPTION="Most commonly needed test functions and features"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-perl/Exception-Class-1.140.0
+ >=dev-perl/Test-Warn-0.230.0
+ >=dev-perl/Test-Deep-0.106
+ >=dev-perl/Test-Differences-0.610.0
+ >=dev-perl/Test-Exception-0.310.0
+ >=virtual/perl-Test-Harness-3.210.0
+ >=virtual/perl-Test-Simple-0.88
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.400.0
+"
+
+SRC_TEST=do
diff --git a/dev-perl/Test-Most/metadata.xml b/dev-perl/Test-Most/metadata.xml
new file mode 100644
index 000000000000..cac37eef5481
--- /dev/null
+++ b/dev-perl/Test-Most/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Test-Most</remote-id>
+ <remote-id type="cpan-module">Test::Most</remote-id>
+ <remote-id type="cpan-module">Test::Most::Exception</remote-id>
+ </upstream>
+</pkgmetadata>