summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Test-Trap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Test-Trap')
-rw-r--r--dev-perl/Test-Trap/Manifest3
-rw-r--r--dev-perl/Test-Trap/Test-Trap-0.2.2-r1.ebuild26
-rw-r--r--dev-perl/Test-Trap/Test-Trap-0.3.0.ebuild31
-rw-r--r--dev-perl/Test-Trap/Test-Trap-0.3.2.ebuild31
-rw-r--r--dev-perl/Test-Trap/metadata.xml16
5 files changed, 107 insertions, 0 deletions
diff --git a/dev-perl/Test-Trap/Manifest b/dev-perl/Test-Trap/Manifest
new file mode 100644
index 000000000000..9d063209db65
--- /dev/null
+++ b/dev-perl/Test-Trap/Manifest
@@ -0,0 +1,3 @@
+DIST Test-Trap-v0.2.2.tar.gz 46055 SHA256 7af9967a771102ebbd88b5f2ccbaf15b0dbea74e22095b0ae7a0a07ad35325b2 SHA512 4131bdb98e1b327c66c9b01f48a58a7aaba7f4805fcc24642cc5f9b6025650f490f38dd90c92897f6b4e12b0ae3db4c7961946b2b2e5df3207493e435beee7b8 WHIRLPOOL a2d05be10c99a3c7e271031d705e41ab54b0492da411e69d43557caf957d5e161d58ddb70853c275de358fceccf4c81d18c9d14cff954d7871a317d47b544715
+DIST Test-Trap-v0.3.0.tar.gz 54147 SHA256 7c840e7dd83369d5d50b60c4bcb6f2a97fc8c8d3d3134de1e5351e0408fb6415 SHA512 cd1e3c806482b16db9a069118a71afc7d20cfc2f18503af84201335c9fd1bc8af4187ab8a299939a500abf2382bd6168bb85db0cc51306c435cd3cffd079a85c WHIRLPOOL 2202b0dcf7c2ed14b1d028aec88dcae6078d603f940504d9348b1f46e8fb6814ee45fc0d7e385e8d9e4c5a4bf6df9ce645e73e6d231fb40f214a02603d1aa74b
+DIST Test-Trap-v0.3.2.tar.gz 54901 SHA256 399b9309c669d161dcd9ee2e1377aa4027e7428ff4f5ffd07cc16852e725054b SHA512 2c8985b316885975b6c07a6da03d55daea8bb212400a5db90ab7aecf1c5a79cd2682db46b39a3353e8bdd4a7e79fef86c26cec731d02561755852e48c09ad129 WHIRLPOOL 71cae91602aeea5d66b92c68800faee0c4ae5f19c8d4f5819a2a10d78618fc9c82bf4edfd440efc39be03bd8c5ca5ec38b0e04495eb33030dbe3feef5aebf8ac
diff --git a/dev-perl/Test-Trap/Test-Trap-0.2.2-r1.ebuild b/dev-perl/Test-Trap/Test-Trap-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..b81bc776e84e
--- /dev/null
+++ b/dev-perl/Test-Trap/Test-Trap-0.2.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=EBHANSSEN
+MODULE_VERSION=v${PV}
+inherit perl-module
+
+DESCRIPTION="Trap exit codes, exceptions, output, etc"
+
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Data-Dump
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.30
+ test? (
+ || ( >=virtual/perl-Test-Simple-1.1.10 dev-perl/Test-Tester )
+ )"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Test-Trap/Test-Trap-0.3.0.ebuild b/dev-perl/Test-Trap/Test-Trap-0.3.0.ebuild
new file mode 100644
index 000000000000..0ba9843ec8ca
--- /dev/null
+++ b/dev-perl/Test-Trap/Test-Trap-0.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=EBHANSSEN
+MODULE_VERSION=v${PV}
+
+inherit perl-module
+
+DESCRIPTION="Trap exit codes, exceptions, output, etc"
+
+SLOT="0"
+KEYWORDS=" ~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# Carp??
+RDEPEND="
+ dev-perl/Data-Dump
+ virtual/perl-Exporter
+ virtual/perl-File-Temp
+ virtual/perl-IO
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.400.3
+ test? (
+ || ( >=virtual/perl-Test-Simple-1.1.10 >=dev-perl/Test-Tester-0.107 )
+ )"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Test-Trap/Test-Trap-0.3.2.ebuild b/dev-perl/Test-Trap/Test-Trap-0.3.2.ebuild
new file mode 100644
index 000000000000..0ba9843ec8ca
--- /dev/null
+++ b/dev-perl/Test-Trap/Test-Trap-0.3.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=EBHANSSEN
+MODULE_VERSION=v${PV}
+
+inherit perl-module
+
+DESCRIPTION="Trap exit codes, exceptions, output, etc"
+
+SLOT="0"
+KEYWORDS=" ~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# Carp??
+RDEPEND="
+ dev-perl/Data-Dump
+ virtual/perl-Exporter
+ virtual/perl-File-Temp
+ virtual/perl-IO
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.400.3
+ test? (
+ || ( >=virtual/perl-Test-Simple-1.1.10 >=dev-perl/Test-Tester-0.107 )
+ )"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Test-Trap/metadata.xml b/dev-perl/Test-Trap/metadata.xml
new file mode 100644
index 000000000000..57ba333f40a7
--- /dev/null
+++ b/dev-perl/Test-Trap/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Test-Trap</remote-id>
+ <remote-id type="cpan-module">Test::Trap</remote-id>
+ <remote-id type="cpan-module">Test::Trap::Builder</remote-id>
+ <remote-id type="cpan-module">Test::Trap::Builder::PerlIO</remote-id>
+ <remote-id type="cpan-module">Test::Trap::Builder::SystemSafe</remote-id>
+ <remote-id type="cpan-module">Test::Trap::Builder::TempFile</remote-id>
+ </upstream>
+</pkgmetadata>