summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-09-23 13:27:17 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-09-23 13:29:28 +0200
commitfaeb8e973f9bb1cddd58a764a2ed1f057b570981 (patch)
treea0b5d6f6f07262b9e933dbbb2cb2f1d841751b94 /dev-perl/Text-Autoformat
parentdev-perl/Text-Aspell: EAPI=8 bump (diff)
downloadgentoo-faeb8e973f9bb1cddd58a764a2ed1f057b570981.tar.gz
gentoo-faeb8e973f9bb1cddd58a764a2ed1f057b570981.tar.bz2
gentoo-faeb8e973f9bb1cddd58a764a2ed1f057b570981.zip
dev-perl/Text-Autoformat: Version bump 1.75
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Text-Autoformat')
-rw-r--r--dev-perl/Text-Autoformat/Manifest1
-rw-r--r--dev-perl/Text-Autoformat/Text-Autoformat-1.750.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Text-Autoformat/Manifest b/dev-perl/Text-Autoformat/Manifest
index 8716818f8c55..fa575567e101 100644
--- a/dev-perl/Text-Autoformat/Manifest
+++ b/dev-perl/Text-Autoformat/Manifest
@@ -1 +1,2 @@
DIST Text-Autoformat-1.74.tar.gz 29485 BLAKE2B e8fca3c994877488ca3f3a98681fc3cc189f8b9294bee775248b9c43a14dad2341f4b92fad201ae4e44dcb4d589631ffb43fcac21ecb44aa186bb0e38cfeb412 SHA512 276e97a0db20032919a6aeacba701350fa8fadf6c1bda7dcda714ef4f1c168b8cc3150a126719d940194c8b20dd534543ec914f03c50e27e4a61b1083ca312c6
+DIST Text-Autoformat-1.75.tar.gz 29621 BLAKE2B c0a27361f4810949596ffa5af46a3f82f26d9b5ef30b2990d26596397c5a7532d227266e3985fa3122d0059d3780bc079e8fd418d04233ce652857f7a5c72836 SHA512 45476dddfd3938561bc0aed9c86cf7876cb823349de815fa511530b80a4049748b4aed2d3135e4349ad1373b8d7fb0a23918a11979ae906551f53f95581c7db2
diff --git a/dev-perl/Text-Autoformat/Text-Autoformat-1.750.0.ebuild b/dev-perl/Text-Autoformat/Text-Autoformat-1.750.0.ebuild
new file mode 100644
index 000000000000..4b00cd0bd953
--- /dev/null
+++ b/dev-perl/Text-Autoformat/Text-Autoformat-1.750.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=NEILB
+DIST_VERSION=1.75
+inherit perl-module
+
+DESCRIPTION="Automatic text wrapping and reformatting"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ dev-perl/Text-Reform
+ virtual/perl-Text-Tabs+Wrap
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.880.0 )
+"
+
+src_install() {
+ perl-module_src_install
+ use examples && perl_doexamples "config.emacs" "config.vim"
+}