summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-04-19 09:52:23 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-23 19:30:44 +0200
commitde41a90b9e509ed2b5ef951976805372c0e58a51 (patch)
treeebf491302e004501b9fa0655468956c78256894c /dev-perl/Tie-LLHash/Tie-LLHash-1.4.0.ebuild
parentdev-perl/Tie-Cycle: Bump to version 1.221.0 (diff)
downloadgentoo-de41a90b9e509ed2b5ef951976805372c0e58a51.tar.gz
gentoo-de41a90b9e509ed2b5ef951976805372c0e58a51.tar.bz2
gentoo-de41a90b9e509ed2b5ef951976805372c0e58a51.zip
dev-perl/Tie-LLHash: Bump to version 1.4.0
- EAPI6 - Author tests cleaned up Upstream: - added explicit SCALAR implementation Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/Tie-LLHash/Tie-LLHash-1.4.0.ebuild')
-rw-r--r--dev-perl/Tie-LLHash/Tie-LLHash-1.4.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/Tie-LLHash/Tie-LLHash-1.4.0.ebuild b/dev-perl/Tie-LLHash/Tie-LLHash-1.4.0.ebuild
new file mode 100644
index 000000000000..7f514f74f83b
--- /dev/null
+++ b/dev-perl/Tie-LLHash/Tie-LLHash-1.4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=XAERXESS
+DIST_VERSION=1.004
+inherit perl-module
+
+DESCRIPTION="Implements an ordered hash-like object"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-solaris"
+IUSE="test"
+
+RDEPEND="virtual/perl-Carp"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.880.0 )
+"
+src_test() {
+ perl_rm_files t/10_changes.t t/11_kwalitee.t
+ perl-module_src_test
+}