summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-04-19 09:58:42 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-23 19:30:44 +0200
commitacd44785df22e7c68aea530b5a0e31191679bd82 (patch)
tree23bbd1b7a0305959fdda34ac1412b171def6ae91 /dev-perl/Tie-Simple/Tie-Simple-1.40.0.ebuild
parentdev-perl/Tie-LLHash: Bump to version 1.4.0 (diff)
downloadgentoo-acd44785df22e7c68aea530b5a0e31191679bd82.tar.gz
gentoo-acd44785df22e7c68aea530b5a0e31191679bd82.tar.bz2
gentoo-acd44785df22e7c68aea530b5a0e31191679bd82.zip
dev-perl/Tie-Simple: Bump to version 1.40.0
- EAPI6 - Versions normalised - Tests cleaned up Upstream: - Fix EXTEND method being missing for arrays - Fix typo in DESTROY method Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'dev-perl/Tie-Simple/Tie-Simple-1.40.0.ebuild')
-rw-r--r--dev-perl/Tie-Simple/Tie-Simple-1.40.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/Tie-Simple/Tie-Simple-1.40.0.ebuild b/dev-perl/Tie-Simple/Tie-Simple-1.40.0.ebuild
new file mode 100644
index 000000000000..c75735db0ccc
--- /dev/null
+++ b/dev-perl/Tie-Simple/Tie-Simple-1.40.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=HANENKAMP
+DIST_VERSION=1.04
+inherit perl-module
+
+DESCRIPTION="Module for creating easier variable ties"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+src_test() {
+ perl_rm_files t/author-pod-{coverage,syntax}.t
+ perl-module_src_test
+}