summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-04-23 22:53:55 -0700
committerMatt Turner <mattst88@gentoo.org>2018-04-26 18:15:59 -0700
commit7cb3cdc2280e3dc3f5300c95bdce809da6103323 (patch)
tree0e4500d1bd0850f201238941be0d8be03ce0ba6c /dev-perl/X11-XCB/X11-XCB-0.170.0-r1.ebuild
parentdev-perl/X11-XCB: Drop old version (diff)
downloadgentoo-7cb3cdc2280e3dc3f5300c95bdce809da6103323.tar.gz
gentoo-7cb3cdc2280e3dc3f5300c95bdce809da6103323.tar.bz2
gentoo-7cb3cdc2280e3dc3f5300c95bdce809da6103323.zip
dev-perl/X11-XCB: Move x11 proto deps to DEPEND
Diffstat (limited to 'dev-perl/X11-XCB/X11-XCB-0.170.0-r1.ebuild')
-rw-r--r--dev-perl/X11-XCB/X11-XCB-0.170.0-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-perl/X11-XCB/X11-XCB-0.170.0-r1.ebuild b/dev-perl/X11-XCB/X11-XCB-0.170.0-r1.ebuild
new file mode 100644
index 000000000000..0c1c088dd58d
--- /dev/null
+++ b/dev-perl/X11-XCB/X11-XCB-0.170.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MSTPLBG
+DIST_VERSION=0.17
+inherit perl-module virtualx
+
+DESCRIPTION="Perl bindings for libxcb"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Data-Dump
+ dev-perl/Mouse
+ dev-perl/MouseX-NativeTraits
+ dev-perl/Try-Tiny
+ dev-perl/XML-Descent
+ dev-perl/XML-Simple
+ >=virtual/perl-XSLoader-0.20.0
+ >=x11-libs/libxcb-1.2
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+"
+DEPEND="${RDEPEND}
+ x11-proto/xcb-proto
+ >=virtual/perl-Devel-PPPort-3.190.0
+ dev-perl/ExtUtils-Depends
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ >=virtual/perl-ExtUtils-ParseXS-3.180.0
+ dev-perl/ExtUtils-PkgConfig
+ dev-perl/XS-Object-Magic
+ test? (
+ dev-perl/Test-Deep
+ dev-perl/Test-Exception
+ virtual/perl-Test-Simple
+ )
+"
+src_compile() {
+ MAKEOPTS="-j1" perl-module_src_compile
+}
+src_test() {
+ virtx perl-module_src_test
+}