summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-04 00:41:14 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-04 00:47:37 +0200
commitb706c59e100926056e062f6be2399eefd38a8c91 (patch)
tree94b968111cb8fd3644ec8b2a607ab6e06724c3cb /dev-perl/XML-Compile
parentdev-perl/XML-CompactTree-XS: EAPI=8 bump (diff)
downloadgentoo-b706c59e100926056e062f6be2399eefd38a8c91.tar.gz
gentoo-b706c59e100926056e062f6be2399eefd38a8c91.tar.bz2
gentoo-b706c59e100926056e062f6be2399eefd38a8c91.zip
dev-perl/XML-Compile: Version bump 1.63
Package-Manager: Portage-3.0.26, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/XML-Compile')
-rw-r--r--dev-perl/XML-Compile/Manifest1
-rw-r--r--dev-perl/XML-Compile/XML-Compile-1.630.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-perl/XML-Compile/Manifest b/dev-perl/XML-Compile/Manifest
index 6458d5b4dfcc..0213055a0c0c 100644
--- a/dev-perl/XML-Compile/Manifest
+++ b/dev-perl/XML-Compile/Manifest
@@ -1 +1,2 @@
DIST XML-Compile-1.60.tar.gz 209090 BLAKE2B 215c043b84f46583cedf12b8be2ed48ce29ce0da45fddbb50135ea0685a3504baba22d61b463e42cfd2090514675396c6e6c400722bdf85b2f9d3a9f59a09015 SHA512 361666004b61bbdf07f62421239120256de3cbf5f17da532c7bab5c8fc9c057638dbf2c26604f8ecea3ef1301364dd945ccc9cbddc358096962d4c289009b61b
+DIST XML-Compile-1.63.tar.gz 210240 BLAKE2B 24d912ecc779b66cc3cff208fbf13852ee362cb8ea4e04a987d7594956fcee0c9dab80a61cd04cddc134a7f1711b52c1396338f01447fbb66e674ff6227094cb SHA512 92f030ae7d54ef9aa82910e570d011cb98eda1546695a26626e5b17bfde7016d155f50ffe87fd4ae4111d075ad852d44fa7183ec96bf0c5cb2a7fba46a1a13db
diff --git a/dev-perl/XML-Compile/XML-Compile-1.630.0.ebuild b/dev-perl/XML-Compile/XML-Compile-1.630.0.ebuild
new file mode 100644
index 000000000000..108ed15d7d03
--- /dev/null
+++ b/dev-perl/XML-Compile/XML-Compile-1.630.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=MARKOV
+DIST_VERSION=1.63
+inherit perl-module
+
+DESCRIPTION="Compilation based XML Processing"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=virtual/perl-Digest-MD5-2.360.0
+ >=virtual/perl-IO-1.220.0
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/Log-Report-1.200.0
+ >=virtual/perl-MIME-Base64-3.100.0
+ >=virtual/perl-Math-BigInt-1.770.0
+ >=virtual/perl-Math-BigRat-0.100.0
+ dev-perl/Types-Serialiser
+ >=dev-perl/XML-LibXML-2.10.700
+ >=virtual/perl-bignum-0.100.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Test-Deep-0.95.0
+ >=virtual/perl-Test-Simple-0.540.0
+ >=dev-perl/XML-Compile-Tester-0.900.0
+ )
+"
+
+src_install() {
+ perl-module_src_install
+ dodoc -r html
+}