summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-05-07 01:50:15 +1200
committerKent Fredric <kentnl@gentoo.org>2020-05-07 01:54:10 +1200
commit19117c246a33cb86e51c1c16c781d2c373ef8f2b (patch)
tree703dcbc422521ce316e529a9f85089a024e5e3d3 /dev-perl/bareword-filehandles/bareword-filehandles-0.7.0.ebuild
parentdev-libs/libutf8proc: add cjk USE flag (diff)
downloadgentoo-19117c246a33cb86e51c1c16c781d2c373ef8f2b.tar.gz
gentoo-19117c246a33cb86e51c1c16c781d2c373ef8f2b.tar.bz2
gentoo-19117c246a33cb86e51c1c16c781d2c373ef8f2b.zip
dev-perl/bareword-filehandles: Bump to version 0.7.0
- EAPI7 Upstream: - Disable checking filetest ops on perl < 5.31.1 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/bareword-filehandles/bareword-filehandles-0.7.0.ebuild')
-rw-r--r--dev-perl/bareword-filehandles/bareword-filehandles-0.7.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/bareword-filehandles/bareword-filehandles-0.7.0.ebuild b/dev-perl/bareword-filehandles/bareword-filehandles-0.7.0.ebuild
new file mode 100644
index 000000000000..fa6b992174f7
--- /dev/null
+++ b/dev-perl/bareword-filehandles/bareword-filehandles-0.7.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ILMARI
+DIST_VERSION=0.007
+inherit perl-module
+
+DESCRIPTION="Disables bareword filehandles"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Lexical::SealRequireHints only required with Perl < 5.12
+# We could add alternation here, but it would be work without benefit
+# which would complicate stabilization
+RDEPEND="
+ dev-perl/B-Hooks-OP-Check
+ virtual/perl-if
+ virtual/perl-XSLoader
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ dev-perl/ExtUtils-Depends
+ test? ( >=virtual/perl-Test-Simple-0.880.0 )
+"