summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/indirect
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/indirect')
-rw-r--r--dev-perl/indirect/Manifest4
-rw-r--r--dev-perl/indirect/indirect-0.270.0.ebuild23
-rw-r--r--dev-perl/indirect/indirect-0.300.0.ebuild23
-rw-r--r--dev-perl/indirect/indirect-0.310.0.ebuild23
-rw-r--r--dev-perl/indirect/indirect-0.350.0.ebuild23
-rw-r--r--dev-perl/indirect/metadata.xml9
6 files changed, 105 insertions, 0 deletions
diff --git a/dev-perl/indirect/Manifest b/dev-perl/indirect/Manifest
new file mode 100644
index 000000000000..b025c5f4cb06
--- /dev/null
+++ b/dev-perl/indirect/Manifest
@@ -0,0 +1,4 @@
+DIST indirect-0.27.tar.gz 38266 SHA256 2d2da4c38eab4a02ac9e616cba8de18d7679a3e3358153791277efbbcb8685b7 SHA512 facc9f4b17308378301781d1ef201d618644b5bd9bc072671bf3d632d7ad7c92a45c94cbf5450887364d9c6b6270a71fa711a2514f49718be9b493d4fb74518c WHIRLPOOL 3b3f3ea0c2d14362100d9062466ae4769df1e133a84456b2c0db3d6c7447d94e99a98a334f2f766029ff68c56f5a6a8f45c986102e289ade79e0a67a6345b9cc
+DIST indirect-0.30.tar.gz 41721 SHA256 f34238760274c7b37858d707a6ffb42663d7ba0aece026fd3692d0382e97378b SHA512 0f272fe7f5d928e8b0d7709589d62a3b9948f55e1a056b927120d50c96a306ea5c1a2031de8decd6dca1fd202b37d2490eef766c7693326d7be580a2d61f7949 WHIRLPOOL acf8f93bc9bdbee5bccd5ab504bd89de52604eaa1c5387b4fdead111f06ed6b4cdef9778fb33dcf63d8a5ed43daea0d4d6c70b042d6288f5541dfb8157f80048
+DIST indirect-0.31.tar.gz 41675 SHA256 9f22be210ea844c266da4008b1046be059888e80072c35a884f6dd67d41c8b99 SHA512 199cfc5fa9a311451daa3d19ace0684afac955879413114f27353e5bc98fbe6f6ab3e7b1881112fca736ef690fd967a7a826de1d2392be94d32c4c4173c05e4b WHIRLPOOL 5801e49a61243659cff1a768d5ab6b56cb0037f227260db807c82006045a159a6727cd1fda311a5dbd3c4314d2bf782a403a7aaf8099c72a3ff596a47848aff3
+DIST indirect-0.35.tar.gz 45177 SHA256 7cebc51f210f8e547e1ca0ff451439edfefb356b4ceb076d8028fb16469e0c74 SHA512 6b3d0e3caec39016172d6fdafaa0fca65d75e63a1131398fe2ce31c08070c70cee0b07112b7fd099a6e4bd0a9e1fe99915259d8752984a5aa462739a2305e50a WHIRLPOOL aac664c4b09c7b97e29ca760f5da64ec40868c045a07eef1a2a53201a071aebcf2a7434a1fbab6a3cddf31e5c43ef12d198b5aa604b30c789194327a90255ef6
diff --git a/dev-perl/indirect/indirect-0.270.0.ebuild b/dev-perl/indirect/indirect-0.270.0.ebuild
new file mode 100644
index 000000000000..3fa25911d396
--- /dev/null
+++ b/dev-perl/indirect/indirect-0.270.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=VPIT
+MODULE_VERSION=0.27
+inherit perl-module
+
+DESCRIPTION="Lexically warn about using the indirect object syntax"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )"
+
+SRC_TEST=do
diff --git a/dev-perl/indirect/indirect-0.300.0.ebuild b/dev-perl/indirect/indirect-0.300.0.ebuild
new file mode 100644
index 000000000000..cf19c04a559f
--- /dev/null
+++ b/dev-perl/indirect/indirect-0.300.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=VPIT
+MODULE_VERSION=0.30
+inherit perl-module
+
+DESCRIPTION="Lexically warn about using the indirect object syntax"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )"
+
+SRC_TEST=do
diff --git a/dev-perl/indirect/indirect-0.310.0.ebuild b/dev-perl/indirect/indirect-0.310.0.ebuild
new file mode 100644
index 000000000000..d5e13b3541eb
--- /dev/null
+++ b/dev-perl/indirect/indirect-0.310.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=VPIT
+MODULE_VERSION=0.31
+inherit perl-module
+
+DESCRIPTION="Lexically warn about using the indirect object syntax"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )"
+
+SRC_TEST=do
diff --git a/dev-perl/indirect/indirect-0.350.0.ebuild b/dev-perl/indirect/indirect-0.350.0.ebuild
new file mode 100644
index 000000000000..de16be1fe844
--- /dev/null
+++ b/dev-perl/indirect/indirect-0.350.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=VPIT
+MODULE_VERSION=0.35
+inherit perl-module
+
+DESCRIPTION="Lexically warn about using the indirect object syntax"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )"
+
+SRC_TEST=do
diff --git a/dev-perl/indirect/metadata.xml b/dev-perl/indirect/metadata.xml
new file mode 100644
index 000000000000..5944926e922d
--- /dev/null
+++ b/dev-perl/indirect/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">indirect</remote-id>
+ <remote-id type="cpan-module">indirect</remote-id>
+ </upstream>
+</pkgmetadata>