summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/namespace-clean
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/namespace-clean')
-rw-r--r--dev-perl/namespace-clean/Manifest2
-rw-r--r--dev-perl/namespace-clean/metadata.xml9
-rw-r--r--dev-perl/namespace-clean/namespace-clean-0.210.0-r1.ebuild22
-rw-r--r--dev-perl/namespace-clean/namespace-clean-0.240.0-r1.ebuild28
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-perl/namespace-clean/Manifest b/dev-perl/namespace-clean/Manifest
new file mode 100644
index 000000000000..7cc9e178ff1e
--- /dev/null
+++ b/dev-perl/namespace-clean/Manifest
@@ -0,0 +1,2 @@
+DIST namespace-clean-0.21.tar.gz 11809 SHA256 b16069bc9261f8c9f2bd541f96076e0961fa4424ce299dac0c9c5523a18e5836 SHA512 927ebed43fad2096705f6633d9eb5d7b4b3ec053b008fc8130886215be482ab373fb2a20ef3404b654ffb49c336e7a5e6a4a4ff6474e9e376b476478b86b68e1 WHIRLPOOL f4a75dd3309fe0744e153cb405b50a6f951640ccfa4001c290f97beeaabbd5640123ccc85fb1c4f7444a266d970b980de829a320246c37e40007c066c16f2a04
+DIST namespace-clean-0.24.tar.gz 12659 SHA256 a661d4484e7de411bc96819aec28805836cfa6a5e276bb3cd346f8e108911230 SHA512 d5c2d0f5aa5b3a64bfae594892177dca14bc22876b983e7b70957ba8f52925c0c87e634d96a48064f50d0f5ce38fdadc58b6b7a4c0140c76602914a960b613ed WHIRLPOOL 3046ca0289fe588e28b8b577a8c6b14a20ce50921e9b39a9ab7a9d3dae51883dd8e21a590506b15751ceefb35c72149c7f29df6c8702384a73bb2ac885462a81
diff --git a/dev-perl/namespace-clean/metadata.xml b/dev-perl/namespace-clean/metadata.xml
new file mode 100644
index 000000000000..2f366eb02b38
--- /dev/null
+++ b/dev-perl/namespace-clean/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">namespace-clean</remote-id>
+ <remote-id type="cpan-module">namespace::clean</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-perl/namespace-clean/namespace-clean-0.210.0-r1.ebuild b/dev-perl/namespace-clean/namespace-clean-0.210.0-r1.ebuild
new file mode 100644
index 000000000000..66a7816ae1d9
--- /dev/null
+++ b/dev-perl/namespace-clean/namespace-clean-0.210.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=RIBASUSHI
+MODULE_VERSION=0.21
+inherit perl-module
+
+DESCRIPTION="Keep imports and functions out of your namespace"
+
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x64-macos"
+IUSE="test"
+
+RDEPEND=">=dev-perl/Package-Stash-0.220"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.31
+ test? ( >=virtual/perl-Test-Simple-0.88 )"
+
+SRC_TEST=do
diff --git a/dev-perl/namespace-clean/namespace-clean-0.240.0-r1.ebuild b/dev-perl/namespace-clean/namespace-clean-0.240.0-r1.ebuild
new file mode 100644
index 000000000000..b27b28590dd5
--- /dev/null
+++ b/dev-perl/namespace-clean/namespace-clean-0.240.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=RIBASUSHI
+MODULE_VERSION=0.24
+inherit perl-module
+
+DESCRIPTION="Keep imports and functions out of your namespace"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~ppc-aix ~x64-macos"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/B-Hooks-EndOfScope-0.120.0
+ >=dev-perl/Package-Stash-0.220.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.310.0
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+SRC_TEST=do