summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-04-11 05:46:14 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-12 00:54:10 +0200
commit7593b3969098bb3611a5949b0be4a39288a5569b (patch)
tree123c5d19e6a06f6d5fc9c64b9de581e87986fca7 /dev-perl/strictures/strictures-2.0.2.ebuild
parentdev-perl/multidimensional: Added at 0.11.0 (diff)
downloadgentoo-7593b3969098bb3611a5949b0be4a39288a5569b.tar.gz
gentoo-7593b3969098bb3611a5949b0be4a39288a5569b.tar.bz2
gentoo-7593b3969098bb3611a5949b0be4a39288a5569b.zip
dev-perl/strictures: Bump to version 2.0.2
- EAPI6 - Expose optional deps via USE="minimal" Upstream: - Packaging changes for compiler detection Keywords: - New deps - Dropped hppa and ppc Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-perl/strictures/strictures-2.0.2.ebuild')
-rw-r--r--dev-perl/strictures/strictures-2.0.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/strictures/strictures-2.0.2.ebuild b/dev-perl/strictures/strictures-2.0.2.ebuild
new file mode 100644
index 000000000000..b52a6c3a0639
--- /dev/null
+++ b/dev-perl/strictures/strictures-2.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=HAARG
+DIST_VERSION=2.000002
+inherit perl-module
+
+DESCRIPTION="Turn on strict and make most warnings fatal"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-aix ~ppc-macos ~x86-solaris"
+IUSE="test minimal"
+
+RDEPEND="
+ !minimal? (
+ dev-perl/bareword-filehandles
+ dev-perl/indirect
+ dev-perl/multidimensional
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"