summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-12-28 20:58:43 +1300
committerKent Fredric <kentnl@gentoo.org>2017-12-30 15:38:45 +1300
commit03d6c2a04a2059d6456d5e716c5765189aef6650 (patch)
tree16153b64c5bd04a4ea667f27088fb2b921c0606f /dev-perl
parentdev-perl/RPC-XML: Bump to version 0.800.0 (diff)
downloadgentoo-03d6c2a04a2059d6456d5e716c5765189aef6650.tar.gz
gentoo-03d6c2a04a2059d6456d5e716c5765189aef6650.tar.bz2
gentoo-03d6c2a04a2059d6456d5e716c5765189aef6650.zip
dev-perl/Authen-Radius: Copy from dev-perl/RadiusPerl
Upstream name change migration Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Authen-Radius/Authen-Radius-0.220.0-r1.ebuild44
-rw-r--r--dev-perl/Authen-Radius/Manifest1
-rw-r--r--dev-perl/Authen-Radius/files/dictionary.cisco.ssg.patch14
-rw-r--r--dev-perl/Authen-Radius/metadata.xml12
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-perl/Authen-Radius/Authen-Radius-0.220.0-r1.ebuild b/dev-perl/Authen-Radius/Authen-Radius-0.220.0-r1.ebuild
new file mode 100644
index 000000000000..157df28ca9cd
--- /dev/null
+++ b/dev-perl/Authen-Radius/Authen-Radius-0.220.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MY_PN=RadiusPerl
+MODULE_AUTHOR=MANOWAR
+MODULE_VERSION=0.22
+inherit perl-module
+
+DESCRIPTION="Communicate with a Radius server from Perl"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~sparc x86"
+IUSE=""
+
+DEPEND="
+ >=virtual/perl-Digest-MD5-2.200.0
+ >=virtual/perl-IO-1.12
+ >=dev-perl/Data-HexDump-0.02
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/Authen-Radius-${MODULE_VERSION}
+
+SRC_TEST="do"
+export OPTIMIZE="$CFLAGS"
+PATCHES=( "${FILESDIR}"/dictionary.cisco.ssg.patch )
+
+src_prepare() {
+ sed -i '/install-radius-db.PL/d' Makefile.PL MANIFEST || die
+ mv "${S}"/install-radius-db.PL{,.orig} || die
+
+ perl-module_src_prepare
+}
+
+src_install() {
+ perl-module_src_install
+
+ # Really want to install these radius dictionaries?
+ insinto /etc/raddb
+ doins raddb/dictionary*
+}
diff --git a/dev-perl/Authen-Radius/Manifest b/dev-perl/Authen-Radius/Manifest
new file mode 100644
index 000000000000..3642180cf55a
--- /dev/null
+++ b/dev-perl/Authen-Radius/Manifest
@@ -0,0 +1 @@
+DIST RadiusPerl-0.22.tar.gz 40980 BLAKE2B 5c8a1870d7a95c89f9f2b8546c0285b5cf62873b3960ee67d45db3c9edfa0117fc40f3238d42a1306a15c4740e739381ae7bb88234bfceff2a79d73a84e384f1 SHA512 d5c7327fa3d4b6f74405e905f01be23479be542073d035c3babc34b63577069f6069e44dda9709b69b5dc25552170a764eb02ab6d2b6c2f7b366da566ae8e967
diff --git a/dev-perl/Authen-Radius/files/dictionary.cisco.ssg.patch b/dev-perl/Authen-Radius/files/dictionary.cisco.ssg.patch
new file mode 100644
index 000000000000..bbec7052ff67
--- /dev/null
+++ b/dev-perl/Authen-Radius/files/dictionary.cisco.ssg.patch
@@ -0,0 +1,14 @@
+--- /etc/raddb/dictionary.cisco 2010-02-10 01:04:00.000000000 +0200
++++ dictionary.cisco 2010-02-10 01:06:10.000000000 +0200
+@@ -118,3 +118,11 @@
+ VALUE Cisco-Disconnect-Cause Session-End-Callback 102
+ VALUE Cisco-Disconnect-Cause Invalid-Protocol 120
+
++#ISG Support http://www.cisco.com/en/US/docs/ios/12_2sb/isg/coa/guide/isgcaapa.html
++ATTRIBUTE Cisco-Policy-Up 37 string Cisco
++ATTRIBUTE Cisco-Policy-Down 38 string Cisco
++ATTRIBUTE Cisco-SSG-Subscriber-Password 249 string Cisco
++ATTRIBUTE Cisco-SSG-Account-Info 250 string Cisco
++ATTRIBUTE Cisco-SSG-Service-Info 251 string Cisco
++ATTRIBUTE Cisco-SSG-Command-Code 252 string Cisco
++ATTRIBUTE Cisco-SSG-Control-Info 253 string Cisco
diff --git a/dev-perl/Authen-Radius/metadata.xml b/dev-perl/Authen-Radius/metadata.xml
new file mode 100644
index 000000000000..d5df1a58b810
--- /dev/null
+++ b/dev-perl/Authen-Radius/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Authen-Radius</remote-id>
+ <remote-id type="cpan-module">Authen::Radius</remote-id>
+ </upstream>
+</pkgmetadata>