summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-06-19 15:39:55 +1200
committerKent Fredric <kentnl@gentoo.org>2020-06-19 15:40:20 +1200
commit119e932066936c7f626fc9b100392f8947c67855 (patch)
tree9ff38f3dfc0ebfc816ccda006d06a772ab5abbbe /dev-perl
parentdev-cpp/eigen: use CPU_FLAGC_PPC, add vsx cpuflag (diff)
downloadgentoo-119e932066936c7f626fc9b100392f8947c67855.tar.gz
gentoo-119e932066936c7f626fc9b100392f8947c67855.tar.bz2
gentoo-119e932066936c7f626fc9b100392f8947c67855.zip
dev-perl/Class-ReturnValue: -r bump for EAPI7
- EAPI7 - Remove useless/empty variable assignments - Parallel tests - Move from "sed" to a patch Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Class-ReturnValue/Class-ReturnValue-0.550.0-r2.ebuild20
-rw-r--r--dev-perl/Class-ReturnValue/files/Class-ReturnValue-0.55-no-dot-inc.patch21
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/Class-ReturnValue/Class-ReturnValue-0.550.0-r2.ebuild b/dev-perl/Class-ReturnValue/Class-ReturnValue-0.550.0-r2.ebuild
new file mode 100644
index 000000000000..9d322eb08fd9
--- /dev/null
+++ b/dev-perl/Class-ReturnValue/Class-ReturnValue-0.550.0-r2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=JESSE
+DIST_VERSION=0.55
+inherit perl-module
+
+DESCRIPTION="A return-value object that lets you treat it as as a boolean, array or object"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+
+RDEPEND="dev-perl/Devel-StackTrace"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.55-no-dot-inc.patch"
+)
diff --git a/dev-perl/Class-ReturnValue/files/Class-ReturnValue-0.55-no-dot-inc.patch b/dev-perl/Class-ReturnValue/files/Class-ReturnValue-0.55-no-dot-inc.patch
new file mode 100644
index 000000000000..8f3a000f9f76
--- /dev/null
+++ b/dev-perl/Class-ReturnValue/files/Class-ReturnValue-0.55-no-dot-inc.patch
@@ -0,0 +1,21 @@
+From 17955682401dcf75f6e71920d64d1f85abc9b138 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Fri, 19 Jun 2020 15:15:25 +1200
+Subject: Include '.' in @INC for perl 5.26+
+
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index ff879d5..301ea88 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,3 +1,4 @@
++use lib '.';
+ use inc::Module::Install;
+
+ name('Class-ReturnValue');
+--
+2.27.0
+